[B2G][Browser]Rendering display issue on foxsports.com - inappropriate boxes appear for title on page

RESOLVED WORKSFORME

Status

Tech Evangelism
Mobile
P4
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Montoya Clemmons (MClemmons), Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: dogfood1.3)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
While viewing foxsports.com using device Browser app, a particular area inserts small gray rectangular boxes making the text display poorly. Since this problem doesn't exist viewing on Buri 1.2, there is something unique with the 1.3 Buri build and may be more widespread than this one website's article

Repro Steps:
1) Updated Buri to BuildID: 20140121004053
2) Tap Browser App 
3) In address bar, type foxsports.com
4) Scroll down to section where a hockey goalie is in a kneeling position with the referee's legs in the background and observe the article title 

Actual:
Text above photo reads three lines of text with small gray rectangular boxes between several text areas

Expected:
Text above photo reads 'It's not worth it' Canada goalie won't bring family to Sochi without small gray rectangular boxes displaying

Repro frequency: (100% - 10 of 10)
See attached: screenshots (1.2 Buri – good display) (1.3 Buri - poor display), text document of HTML code for section reported with problem

Other information: 

1. Text appears good on Firefox OS browser without the small gray rectangular boxes
2. Text appears good on browser of user personal Android device without small gray rectangular boxes
3. Text appears good on Buri 1.2 without small gray rectangular boxes
4. Other areas on foxsports.com website with apostrophes and/or quotes don't display the reported behavior
5. Viewing the source code from computer for this text reads correctly 
6. Copying and pasting the HTML from source code on computer displays inappropriately in MS Word or a text file - shows similar characters as on 1.3 Buri - however displays properly when copied within Bugzilla (example below)
<h1>
'€˜It'™s not worth it': Canada goalie won'€™t bring family to Sochi
</h1>
7. Display on Buri 1.3 is the same on homepage of Foxsports.com as well if user taps on the story link – the title displays similarly inappropriately as on homepage
8. Display on Buri 1.3 did not change when changing the Settings App - Device Information - More Information - Developer Settings to enable APZ for all conte..it was the same as when it was not enabled


Environmental Variables
Device: Buri 1.3 MOZ
BuildID: 20140121004137
Gaia: 47049555282a9a01fb60d1e1421b57e2810c96f5
Gecko: 6f7dfe36ab6c
Version: 28.0a2
Base Image: v1.2-device.cfg
(Reporter)

Comment 1

4 years ago
Created attachment 8364603 [details]
HTML for title section of page with error
(Reporter)

Comment 2

4 years ago
Created attachment 8364604 [details]
Screenshot of 1.2 Buri display
(Reporter)

Comment 3

4 years ago
Created attachment 8364606 [details]
Buri1.3PoorDisplay
(Reporter)

Comment 4

4 years ago
This issue does not reproduce on Buri 1.2

Display of text doesn't contain gray boxes. Screenshot is attached to case. (Screenshot of 1.2 Buri display) 

Environmental Variables

Device: Buri 1.2 COM
BuildID: 20140121004053
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: c9f305c1d9a7
Version: 26.0
RIL Version: 01.02.00.019.102
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
blocking-b2g: --- → 1.3?
Component: Gaia::Browser → Layout
Product: Firefox OS → Core
Version: unspecified → 28 Branch

Updated

4 years ago
QA Contact: nkhristoforov
Likely a regression from bug 909344.  See also bug 947588 for discussion.
Blocks: 909344
Component: Layout → Layout: Text
Depends on: 947588
Priority: -- → P4

Comment 6

4 years ago
The bug stopped reproducing during my search for the regression-window. I was able to reproduce the issue on the 01/23, 01/21, 12/10, and 12/09 builds. When I flashed to the 12/01 build the bug stopped reproducing. However, I was not able to reproduce the bug again on any future builds including the ones where it reproduced before and the latest 1.3 build. I followed the same STR so I'm not sure if Fox Sports changed something during my search or if it's something else. Leaving regressionwindow-wanted tag in case others can find the window.

Device: Buri 1.3 MOZ
BuildID: 20140124004002
Gaia: e5137ed5589d7f3bf0260b8920f874cd0f462f69
Gecko: a73b697b50b3
Version: 28.0a2
Firmware Version: V1.2-device.cfg
(In reply to Nikolai Khristoforov from comment #6)
> The bug stopped reproducing during my search for the regression-window. I
> was able to reproduce the issue on the 01/23, 01/21, 12/10, and 12/09
> builds. When I flashed to the 12/01 build the bug stopped reproducing.
> However, I was not able to reproduce the bug again on any future builds
> including the ones where it reproduced before and the latest 1.3 build. I
> followed the same STR so I'm not sure if Fox Sports changed something during
> my search or if it's something else. Leaving regressionwindow-wanted tag in
> case others can find the window.
> 
> Device: Buri 1.3 MOZ
> BuildID: 20140124004002
> Gaia: e5137ed5589d7f3bf0260b8920f874cd0f462f69
> Gecko: a73b697b50b3
> Version: 28.0a2
> Firmware Version: V1.2-device.cfg

We've already got a suspected bug, so don't worry about this.
Keywords: regressionwindow-wanted
Yes, these were hexboxes being rendered because of spurious control characters within the text. This is a website error; most likely caused by incorrect management of charsets, encoding conversion, etc., somewhere in the authoring/publishing toolchain.

From comment 6, it sounds like the site may have fixed the problem at their end. (Quite likely it was the fact that Firefox makes the garbage control codes visible that led them to realize their workflow was broken, and do something about it.)
Okay - I'll mark wfm then.
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Last Resolved: 4 years ago
Component: Layout: Text → Mobile
Product: Core → Tech Evangelism
Resolution: --- → WORKSFORME
Version: 28 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.