Often crash while typing in the URL bar

VERIFIED DUPLICATE of bug 96232

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 96232
17 years ago
17 years ago

People

(Reporter: Simon Fraser, Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
My carbon build running on X is crashing while typing in the URL bar. This 
is somewhat sporadic, but quite frequent. gdb says:

Program received signal EXC_BAD_INSTRUCTION, Illegal instruction/
operand.
0x0405c020 in ?? ()
(gdb) bt
#0  0x0405c020 in ?? ()
#1  0x02075734 in 
HandleKeyEvent__17nsMacEventHandlerFR11EventRecord ()
#2  0x02072cec in HandleOSEvent__11nsMacWindowFR11EventRecord 
()
#3  0x0207992c in 
DispatchOSEvent__16nsMacMessageSinkFR11EventRecordP15Opaque
WindowPtr ()
#4  0x0207f010 in 
DispatchOSEventToRaptor__16nsMacMessagePumpFR11EventRecord
P15OpaqueWindowPtr ()
#5  0x0207ecac in DoKey__16nsMacMessagePumpFR11EventRecord ()
#6  0x0207dfc8 in 
DispatchEvent__16nsMacMessagePumpFiP11EventRecord ()
#7  0x0207d7a8 in DoMessagePump__16nsMacMessagePumpFv ()
#8  0x0207ce30 in Run__10nsAppShellFv ()
#9  0x01d0c220 in Run__17nsAppShellServiceFv ()
#10 0x00fb4ca8 in main1 ()
#11 0x00fb7a5c in main ()
not just osx...


*** This bug has been marked as a duplicate of 96232 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Yep. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.