Closed Bug 963355 Opened 8 years ago Closed 8 years ago

[B2G][Browser]Navigation sidebar on foxsports.com demonstrates unexpected behavior and displays poorly at footer on device

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g18 affected, b2g-v1.2 affected, b2g-v1.3 affected)

RESOLVED INVALID
Tracking Status
b2g18 --- affected
b2g-v1.2 --- affected
b2g-v1.3 --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: dogfood1.3)

While viewing foxsports.com using device Browser app, the Big Board section of the page - normally on the right side of the page on the desktop Firefox browser version displays on the bottom of the page as a black scrolling bar. However, when user scrolls on device vertically, the bar blends into the written content following the direction of the user's scrolling motion. The text within the Big Board section vanishes and reappears (summary, scores, schedules, etc.) during this user experience.

Repro Steps:
1) Updated Buri to BuildID: 20140121004053
2) Tap Browser App 
3) In address bar, type foxsports.com
4) Wait for the page to fully loaded (heavy content site) so that the black bar at the bottom of the page displays with text (summary, scores, etc.)
5) Scroll in a vertical motion on device

Actual:
when user scrolls on device vertically, the footer bar blends into the written content of the articles on the page with the text within the Big Board section vanishing and reappearing

Expected:
when user scrolls on device vertically, the bar remains stationary and doesn't blend into written text of articles on the page

Repro frequency: (100% - 10 of 10)
See attached: video on youtube http://youtu.be/VOmL7f4emLA
Other information: 
1. Desktop Firefox OS browser doesn't reproduce the reported behavior
2. Behavior reproducible with cookies, stored data, and browsing history cleared as well as surfing after many minutes with no changes to the cookies, stored data and browsing history section in the Browser app
3. Overall navigation on Buri 1.3 is problematic as attempts to scroll on the page is very sensitive, a light touch and scroll (as demonstrated on the video attached) will open an article even when not intended by user

Environmental Variables
Device: Buri 1.3 MOZ
BuildID: 20140121004137
Gaia: 47049555282a9a01fb60d1e1421b57e2810c96f5
Gecko: 6f7dfe36ab6c
Version: 28.0a2
Base Image: v1.2-device.cfg
This issue reproduces on Buri 1.2 COM. 

When user scrolls on device vertically, the footer bar blends into the written content of the articles on the page with the text within the Big Board section vanishing and reappearing. Navigation is not as sensitive on Buri 1.2 as was the case with Buri 1.3

Environmental Variables
Device: Buri 1.2 COM
BuildID: 20140121004053
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: c9f305c1d9a7
Version: 26.0
RIL Version: 01.02.00.019.102
This issue reproduces on Buri 1.1

When user scrolls on device vertically, the footer bar blends into the written content of the articles on the page with the text within the Big Board section vanishing and reappearing.

Navigation is not as sensitive on Buri 1.1 as was the case with Buri 1.3

Environmental Variables
Device: Buri 1.1 COM
BuildID: 20140121041200
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Gecko: e7a8e7b9b7d2
Version: 18.0
RIL Version: 01.01.00.019.281
Component: Gaia::Browser → Mobile
Product: Firefox OS → Tech Evangelism
Good observation but the site does this on purpose - when you scroll down, the bar collapses to maximize reading space
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.