Closed Bug 963639 Opened 6 years ago Closed 6 years ago

CustomizeMode _onToolbarVisibilityChange sets @customizing on non-customizable toolbars

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 + fixed
firefox30 --- fixed

People

(Reporter: MattN, Assigned: Gijs)

References

()

Details

(Keywords: regression, Whiteboard: [Australis:P3])

Attachments

(1 file)

This is just wrong and should be fixed. It may cause areas to be highlighted/treated as customizable when they are not.
Seems to me this is all that needs to happen, right? I hope you don't mind that I'm stealing this, it's so low effort that I figured we should just take the fix already.
Attachment #8371463 - Flags: review?(mnoorenberghe)
Assignee: MattN+bmo → gijskruitbosch+bugs
Attachment #8371463 - Flags: review?(mnoorenberghe) → review?(MattN+bmo)
Comment on attachment 8371463 [details] [diff] [review]
only make Australis customization mode set customizing=true on toolbars which are customizable,

Review of attachment 8371463 [details] [diff] [review]:
-----------------------------------------------------------------

That's fine that you took it. I wasn't going to get to it this week. That's all I had in mind for the fix too so r=me. Of course a simple test would be nice but I'm not sure it's worth the effort at this point. I'll mark in-testsuite? so someone can come back and write a test.
Attachment #8371463 - Flags: review?(MattN+bmo) → review+
Flags: in-testsuite?
Comment on attachment 8371463 [details] [diff] [review]
only make Australis customization mode set customizing=true on toolbars which are customizable,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: add-on toolbars could start behaving weirdly in customize mode if removed/re-added
Testing completed (on m-c, etc.): local
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none

remote:   https://hg.mozilla.org/integration/fx-team/rev/34922bfad654
Attachment #8371463 - Flags: checkin+
Attachment #8371463 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/34922bfad654
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Attachment #8371463 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Target Milestone: Firefox 30 → ---
Target Milestone: --- → Firefox 30
The automated test for this was tracked in bug 977033 and was landed in https://hg.mozilla.org/mozilla-central/rev/d36aeeed76a9
Flags: in-testsuite? → in-testsuite+
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.