Closed Bug 963793 Opened 7 years ago Closed 7 years ago

fix to have user story field available on bug creation

Categories

(bugzilla.mozilla.org :: Extensions, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jgong, Assigned: dkl)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #879385 +++

Bug 879385 created an editable "user story" field for requirements tracking.  You can't set user story while filing the bug only after first filing the bug, the user story option shows up. I would like to put a fix to have the user story field available on bug creation. 








As a product manager I'd like to be able to enter my user story into an editable text field in the "Tracker" product, in a placement on the page permanently above the bug comments and requirements discussions so that it is always prominent & visible. This will enable me to track user story delivery in bugzilla.

As a program manager, I'd like to be able to enter my business requirement into an editable text field in the "Tracker" product, in a placement on the page permanently above the bug comments and requirements discussions so that it is always prominent and visible. This will enable me to track my project scope in bugzilla.

Workflow:
1 - create user story
2 - share with dev, ux, qa, program team members etc
3 - gather comments on the bug
4 - adjust / finalize story
5 - review with devs
6 - devs create dev tasks and tech requirements as usual, in their own product areas of bugzilla

This is a request for an editable field in the "Tracker" product of Bugzilla 
Placement. This will enable requirements tracking / editing **while we are waiting** for the requirements tracking tool to be put into use.

OUT OF SCOPE
It does NOT request any additional functionality (like "locking" this edit field once final story is published or restricting that field to only certain users). We'd need to be good product and program folks and not touch each other's work product without agreement.
Summary: [story] custom, editable field for the purposes of requirements tracking → [story] fix to have user story field available on bug creation
Byron, I had submitted this bug in January to address a problem with the original request Bug 879385.   It's critical we have this fix since we are going to start entering user stories for upcoming release planning.
Flags: needinfo?(glob)
sorry this was missed - this bug was filed in a component we don't use for tracking bugzilla development.
Component: User Story → Extensions: Other
Flags: needinfo?(glob)
Product: Tracking → bugzilla.mozilla.org
Summary: [story] fix to have user story field available on bug creation → fix to have user story field available on bug creation
Version: --- → Production
Bryon, thanks!  What is the ETA for this?
(In reply to Jean Gong from comment #3)
> Byron, thanks!  What is the ETA for this?

sorry, it's difficult to provide a clear estimate for this.  hopefully within 3 to 4 weeks.
Assignee: nobody → dkl
Attached patch 963793_1.patchSplinter Review
Also took liberty of refactoring how cf_crash_signature works to be consistent with cf_user_story when entering a new bug.

dkl
Attachment #8404275 - Flags: review?(glob)
(In reply to David Lawrence [:dkl] from comment #5)
> Created attachment 8404275 [details] [diff] [review]
> 963793_1.patch
> 
> Also took liberty of refactoring how cf_crash_signature works to be
> consistent with cf_user_story when entering a new bug.

Forgot to mention to also be sure to enable the cf_user_story field for bug creation in editfields.cgi for this to work properly.

dkl
(In reply to Byron Jones ‹:glob› (unavailable until apr 21st) from comment #4)
> (In reply to Jean Gong from comment #3)
> > Byron, thanks!  What is the ETA for this?
> 
> sorry, it's difficult to provide a clear estimate for this.  hopefully
> within 3 to 4 weeks.

Ok. Bryon thanks for the update.

Jean
Comment on attachment 8404275 [details] [diff] [review]
963793_1.patch

Review of attachment 8404275 [details] [diff] [review]:
-----------------------------------------------------------------

r=glob very nice.
Attachment #8404275 - Flags: review?(glob) → review+
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   96ff287..c4da32d  master -> master
Status: NEW → RESOLVED
Closed: 7 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Depends on: 1018668
Depends on: 1047142
Duplicate of this bug: 975421
Component: Extensions: Other → Extensions
You need to log in before you can comment on or make changes to this bug.