Closed Bug 963875 Opened 6 years ago Closed 6 years ago

[B2G][SMS] "Service currently unavailable " message provides a user with an incorrect information

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sarsenyev, Assigned: ankit93040)

References

Details

(Whiteboard: [g+][LibGLA, Dev, B] )

Attachments

(2 files, 2 obsolete files)

Attached image 2014-01-24-13-50-53.png
Description:
When no service is available and SMS cannot be sent, the warning message pops up: "Service unavailable: message will automatically sent once service is available", but in reality the message won't be sent automatically to resend the failed message a user needs to tap the failed message and confirm that he want resend it
It could be really confusing for the user

Repro Steps:
1) Updated Buri to BuildID: 20140124004002
2) Lost a signal with "signal shielding"
4) Open SMS app from the home screen
5) Send any SMS to a real address
6) When the warning message appears tap "OK" bar
7) Return the network signal 

Actual:
The message won't be sent automatically when service is come back until the user tap the exclamation icon and confirm his actions 

Expected:
If message notifying the user that the message will be sent automatically, the failed message should be resend automatically
If SMS doesn't resend automatically the text should be changed 

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140124004002
Gaia: e5137ed5589d7f3bf0260b8920f874cd0f462f69
Gecko: a73b697b50b3
Version: 28.0a2
RIL Version: 01.02.00.019.102
Firmware Version: Settings > Device Information > More Information > Firmware revision (example.D30008m)

Notes:
Repro frequency: 100%
See attached: screenshot
What happens on 1.1?
Keywords: qawanted
AFAIK this is the same erroneous message and behavior since 1.1.

See bug 917954 comment 24 for all the correct strings we should use.

I really thought we fixed the bad generic message in bug 928330 (I wanted to!) but I looked up the patch and we unfortunately kept it.

It's probably too late for 1.3 but I want to fix this for 1.4.
blocking-b2g: --- → 1.4?
Issue reproduces on 1.1, same message appears on 1.1

Gaia   c434fe9a0e823029796805e141cfa983cda2d246
SourceStamp aa0ceb07a73e
BuildID 20140123041201
Version 18.0
Keywords: qawanted
comms triage: not a blocker, ask for approval when ready.
blocking-b2g: 1.4? → ---
Hey!

What should be the updated message?

I think "service currently unavailable" message is wrong because network shows the signal when these message is shown.

"Message will automatically be sent..." is definitely wrong.

I want to fix these. 

Kindly provide your inputs!
Flags: needinfo?(schung)
Flags: needinfo?(aymanmaat)
Hi Omage, since we will not try to resend the message automatically, do you have any about the error message(like 'please retry later when service available')? Thanks.
Flags: needinfo?(schung)
Flags: needinfo?(ofeng)
Flags: needinfo?(aymanmaat)
Hi steve & Omage

We can't use the term "service available" at all because the network then shows signal.

I feel that it even can't be "Please try later" because even if the user tries later again they will get the same message.

I think there shouldn't be any message at all, instead it should be sent & in the conversation it should be marked with red(!) indicating that it was not sent.
Flags: needinfo?(schung)
Maybe we can just use "Message cannot be sent."
Flags: needinfo?(ofeng)
Please see comment 2, I already gave this information...

Title is: 'Message not sent';
Body is: 'There was a problem sending the message. Please try again.';
OK button is: 'OK';
Flags: needinfo?(schung)
Attached patch 963875.patch (obsolete) — Splinter Review
Hi Steve

As per Julien's comment # 9 I modified the error message.

Kindly have a look at it.

thanks!
Attachment #8395607 - Flags: review?(schung)
Hi Julein 

As you said in comment # 9:-

Body is: 'There was a problem sending the message. Please try again.';

"Please try again" - Even if the user tries again then again they'll get the same message. isn't it?

I think it's better not to have "Please try again".

As far as I understand that these message is prompted when the user enters a wrong number in the "To Field" hence it's better to have the Body of the message as - "Please re check the recipients number & try again".

As in the user must know the reason as to What is wrong only then the user can rectify its mistake?

What say?
Flags: needinfo?(felash)
The message can happen for a variety of reasons, not only for this reason. For example, the message can happen if there is a network issue.
Flags: needinfo?(felash)
Comment on attachment 8395607 [details] [diff] [review]
963875.patch

Review of attachment 8395607 [details] [diff] [review]:
-----------------------------------------------------------------

Please use another name if we change the l10n string(maybe repalcing the 'general' with 'default'), and don't forget the relative changes in dialog.js/dialog_test.js
Attachment #8395607 - Flags: review?(schung)
Attached file Pointer to Pull Request.html (obsolete) —
Hi Steve

Please assign the bug in my name.

Please find the attached pull request for the same.

thanks!
Attachment #8395607 - Attachment is obsolete: true
Attachment #8396151 - Flags: review?(schung)
Assignee: nobody → ankit93040
Comment on attachment 8396151 [details]
Pointer to Pull Request.html

Only one comment here https://github.com/mozilla-b2g/gaia/pull/17558/files#r10919372. Maybe we should verify the button is translated or not.
Hey Steve

Modified my previous pull request as in comment # 14.

Kindly Merge it to master.

thanks!
Attachment #8396151 - Attachment is obsolete: true
Attachment #8396151 - Flags: review?(schung)
Attachment #8396204 - Flags: review?(schung)
Comment on attachment 8396204 [details]
Pointer to Pull Request.html

r=me, thanks!
Attachment #8396204 - Flags: review?(schung) → review+
Landed in master: 9e0e7d226b71338d59902e38d4bdb9226b222f36
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [g+]
Whiteboard: [g+] → [g+][LibGLA, Dev, B]
You need to log in before you can comment on or make changes to this bug.