Firefox will not restart after it is closed while playing an MP3 or OGG file

RESOLVED DUPLICATE of bug 938107

Status

()

RESOLVED DUPLICATE of bug 938107
5 years ago
5 years ago

People

(Reporter: fstanek, Unassigned)

Tracking

26 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.76 Safari/537.36

Steps to reproduce:

Launch a file with the following script:

var audio = new Audio('1-01.mp3');
audio.play();

then close the browser window while the audio is playing. Then, attempt to open firefox.

To see the problem in action, I created a test page here.

http://www.bloodforge.com/ff-bug/

BTW, my firefox version in 'about' is 26. I'm assuming that is the same thing as '26 branch'


Actual results:

I get an error message that firefox is already running but not responding.


Expected results:

Firefox should have opened.

Comment 1

5 years ago
Easily reproducible on my computer using the test page provided. I see a 100% zombie process on shutdown testing with a new profile under latest Nightly 29 on Linux. However, I could not reproduce this under WinXP or Win7 in my test VM.
Status: UNCONFIRMED → NEW
Component: Untriaged → Video/Audio
Ever confirmed: true
OS: Windows 8.1 → All
Product: Firefox → Core
Hardware: x86_64 → All

Comment 2

5 years ago
reporter is on Win8.1

(it would be nice if Bugzilla let me set discreet affected platforms rather than just one or all, but it doesn't)
I'm betting this is bug 938107. This should be fixed in Firefox 27.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938107

Comment 4

5 years ago
(In reply to Chris Pearce (:cpearce) from comment #3)
> I'm betting this is bug 938107. This should be fixed in Firefox 27.

(In reply to Dave Garrett from comment #1)
> 100% zombie process on shutdown testing with a new profile under latest
> Nightly 29 on Linux.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

5 years ago
Status: REOPENED → NEW
WFM on Windows.

Can you find a regression range on Linux?

Comment 6

5 years ago
Reproducible in current stable 26 as well as ESR 24.2 (with gstreamer enabled via about:config) on Linux. I don't think I can go further back and have any expectation that it should work at all, seeing as Linux support was added late.

As already said above, this is also WFM under Windows XP & 7 for me (in a VirtualBox). The reporter is on Windows 8.1 and I'm on Kubuntu 10.04 (KDE-flavored Ubuntu, previous LTS).

Is there a Win8.1 test box you can test? (I don't have a VM for Win8)

I'm going to modify this testcase to test ogg instead of mp3 and give that a test too.

Comment 7

5 years ago
I can't reproduce this locally with an ogg file. :/
I'm testing Nightly 2014-01-20 on a Win8.1 box, not in a VM. What exact version of Nightly are you testing?

Comment 9

5 years ago
(In reply to Chris Pearce (:cpearce) from comment #8)
> I'm testing Nightly 2014-01-20 on a Win8.1 box, not in a VM. What exact
> version of Nightly are you testing?

I just pulled up a new profile in current nightly, loaded up the URL in comment 0, closed Nightly and got a hang. Had to terminate the process. (previous tests were with "-no-remote" with my main profile open with this bug; I just tested again with no other Firefox processes open just to be sure and it still hangs) This is the latest Nightly pulled off of FTP. Version from about dialog and changeset from about:buildconfig:

Nightly 29.0a1 (2014-01-28)
http://hg.mozilla.org/mozilla-central/rev/4da3e21a0e5f

Comment 10

5 years ago
Reporter tested this in 26, by the way, not nightly.

Filip: Could you give things a test in a new profile with current nightly as well? It's entirely possible it's no longer an issue for Windows and just hits me on Linux now.

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
https://nightly.mozilla.org/
Flags: needinfo?(fstanek)
(Reporter)

Comment 11

5 years ago
(In reply to Dave Garrett from comment #10)
> Reporter tested this in 26, by the way, not nightly.
> 
> Filip: Could you give things a test in a new profile with current nightly as
> well? It's entirely possible it's no longer an issue for Windows and just
> hits me on Linux now.
> 
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles
> https://nightly.mozilla.org/

I uninstalled FF, installed the nightly, and I was unable to reproduce the issue on Win 8.1, so it appears to be fixed.

I looked back through my emails, and this bug was seen in our lab on Vista, Win7, and Win8.  

I created a separate test page for an OGG file at http://www.bloodforge.com/ff-bug/ogg.html . It is much more difficult to reproduce this issue with OGGs (initially, I thought I had a workaround for this bug when I switched to OGGs, but our lab caught that). For the OGG test case, I think it took me about 20 or 30 tries to reproduce the problem on v26. I just set it to my homepage and opened and closed the browser after audio played and eventually it happened (I'm actually surprised our lab found it).
Flags: needinfo?(fstanek)

Comment 12

5 years ago
(In reply to Filip Stanek from comment #11)
> I uninstalled FF, installed the nightly, and I was unable to reproduce the
> issue on Win 8.1, so it appears to be fixed.
> 
> I looked back through my emails, and this bug was seen in our lab on Vista,
> Win7, and Win8.  

Well, in that case, I need to file a separate bug for Linux -> bug 965523

This is either WFM or is actually a dupe of bug 938107 and that just isn't actually fixed for Linux. I'll close this out then.
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 938107

Updated

5 years ago
See Also: → bug 965523
You need to log in before you can comment on or make changes to this bug.