Whitelist more syscalls: msync (asm.js cache), sched_get_priority_m{in,ax} (webrtc)

RESOLVED FIXED in mozilla29

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jld, Assigned: jld)

Tracking

Trunk
mozilla29
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1. The asm.js cache (bug 929236) uses msync via PR_SyncMemMap.  We allow fsync, and this is more or less the same thing.

2. webrtc::ThreadPosix::Start() calls sched_get_priority_min and sched_get_priority_max; see also getpriority and setpriority, which we currently allow.
Created attachment 8366255 [details] [diff] [review]
bug964427-whitelist-msync-priominmax-hg0.diff
Attachment #8366255 - Flags: review?(gdestuynder)
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/151feb1e7b8b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Duplicate of this bug: 976660
You need to log in before you can comment on or make changes to this bug.