Closed Bug 964510 Opened 6 years ago Closed 6 years ago

Add a browser-delayed-startup-finished notification

Categories

(Firefox for Android :: General, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: wesj, Assigned: wesj)

References

Details

Attachments

(1 file, 1 obsolete file)

We can fire something after the first page has loaded and move non-critical startup stuff there.
Attached patch Patch v1 (obsolete) — Splinter Review
Attachment #8366284 - Flags: review?(mark.finkle)
Comment on attachment 8366284 [details] [diff] [review]
Patch v1

If this function/handler gets anymore code in it we should make it a "real" method of BrowserApp. Fine for now as it is.
Attachment #8366284 - Flags: review?(mark.finkle) → review+
Hi, sorry backedout as part of https://tbpl.mozilla.org/?tree=Fx-Team&rev=c15e29ead092 for the suspicion of causing robocop testfailures on android like https://tbpl.mozilla.org/php/getParsedLog.php?id=33734468&tree=Fx-Team
Attached patch af74d0fd42e1Splinter Review
Same exact patch, but also fires a notification to Java for delayed startup.
Attachment #8366284 - Attachment is obsolete: true
Attachment #8369089 - Flags: review?(mark.finkle)
Attachment #8369089 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/b8c9dc39af31
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
backed out for startup regressions:
https://hg.mozilla.org/integration/fx-team/rev/c80398db6447
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8369089 [details] [diff] [review]
af74d0fd42e1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This caused a startup regression. I'd actually like to uplift the backout.
User impact if declined: Startup regression. Yeah that makes no sense.
Testing completed (on m-c, etc.): Has been on central. Seemed to help eideticker.
Risk to taking this patch (and alternatives if risky): Low risk. A Backout
String or IDL/UUID changes made by this patch: none.
Attachment #8369089 - Flags: approval-mozilla-aurora?
Blocks: 964511
Relanding this on central actually. This SHOULD have no affect on startup by itself. Then we can layer on other pieces slowly.

https://hg.mozilla.org/integration/fx-team/rev/79bc2b2768e4
Attachment #8369089 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/79bc2b2768e4
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 29 → Firefox 30
Should the milestone be 29 here? It seems like the backout did not get uplifted.
Target Milestone: Firefox 30 → Firefox 29
You need to log in before you can comment on or make changes to this bug.