support scientific (exponential) notation in CSS properties

RESOLVED FIXED in mozilla29

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

(Depends on: 1 bug, {dev-doc-complete})

Trunk
mozilla29
dev-doc-complete
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
The CSS Working Group agreed to support scientific notation in CSS properties (not just SVG attributes).
(Assignee)

Comment 1

3 years ago
Created attachment 8366324 [details] [diff] [review]
Support scientific (exponential) notation for CSS <number> values, including percentages and dimensions (but not <integer> values).

Resolved for <number> on 2012-08-15:
http://lists.w3.org/Archives/Public/www-style/2012Aug/0900.html

Resolved for percentages and dimensions in CSS teleconference 2013-04-17:
http://lists.w3.org/Archives/Public/www-style/2013Apr/0428.html
Attachment #8366324 - Flags: review?(cam)
Comment on attachment 8366324 [details] [diff] [review]
Support scientific (exponential) notation for CSS <number> values, including percentages and dimensions (but not <integer> values).

Review of attachment 8366324 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #8366324 - Flags: review?(cam) → review+
(Assignee)

Comment 3

3 years ago
fantasai thinks I should keep the value lists for widows and orphans the same, and also have tests for e notation on things with a .
(Assignee)

Comment 4

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/699811c420a2
Backed out for crashtest asserts.
https://hg.mozilla.org/integration/mozilla-inbound/rev/1e7b2bb3041b

https://tbpl.mozilla.org/php/getParsedLog.php?id=33897873&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=33897837&full=1&branch=mozilla-inbound#error0
(Assignee)

Comment 6

3 years ago
https://tbpl.mozilla.org/?tree=Try&rev=876c97def8d2
(Assignee)

Comment 7

3 years ago
   https://hg.mozilla.org/integration/mozilla-inbound/rev/56aaeebb639f
   https://hg.mozilla.org/integration/mozilla-inbound/rev/ce3bd1ad8565
https://hg.mozilla.org/mozilla-central/rev/56aaeebb639f
https://hg.mozilla.org/mozilla-central/rev/ce3bd1ad8565
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
(Assignee)

Updated

3 years ago
Keywords: dev-doc-needed
Duplicate of this bug: 968664

Updated

3 years ago
Flags: in-testsuite?
(Assignee)

Updated

3 years ago
Flags: in-testsuite? → in-testsuite+
Blocks: 893820
Doc up-to-date:
https://developer.mozilla.org/en-US/Firefox/Releases/29#CSS
and
https://developer.mozilla.org/en-US/docs/Web/CSS/number
(All other valid cases says that it is a <number> followed by a given unit.

Also I added an example about the scientific notation not being valid in 
https://developer.mozilla.org/en-US/docs/Web/CSS/integer
Keywords: dev-doc-needed → dev-doc-complete
(Assignee)

Updated

a year ago
Depends on: 1249755
You need to log in before you can comment on or make changes to this bug.