Intermittent TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_bug654550.html | mozParsedFrames should be 0 if stats are disabled

RESOLVED FIXED in Firefox 38

Status

()

Core
Audio/Video
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Tomcat, Assigned: jwwang)

Tracking

(Blocks: 1 bug, {intermittent-failure})

Trunk
mozilla38
x86
Linux
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox37 unaffected, firefox38 fixed, firefox-esr31 unaffected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
b2g_emulator_vm mozilla-inbound opt test mochitest-2 on 2014-01-27 20:12:43 PST for push 42bb4abbd6c9

slave: tst-linux64-spot-304

https://tbpl.mozilla.org/php/getParsedLog.php?id=33670296&tree=Mozilla-Inbound



35329 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_bug654550.html | mozParsedFrames should be 0 if stats are disabled
35330 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_bug654550.html | mozDecodedFrames should be 0 if stats are disabled
35331 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_bug654550.html | mozPresentedFrames should be 0 if stats are disabled
35332 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_bug654550.html | mozPaintedFrames should be 0 if stats are disabled
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

4 years ago
Assignee: nobody → jwwang
(Assignee)

Comment 11

4 years ago
Created attachment 8371376 [details] [diff] [review]
part1_pushPrefEnv-v1.patch

Looks like another bug caused by SpecialPowers.setBoolPref. Will use SpecialPowers.pushPrefEnv instead.
Attachment #8371376 - Flags: review?(jsmith)
Comment on attachment 8371376 [details] [diff] [review]
part1_pushPrefEnv-v1.patch

Redirecting to Paul as he's reviewed this mochitest previously.
Attachment #8371376 - Flags: review?(jsmith) → review?(paul)

Updated

4 years ago
Attachment #8371376 - Flags: review?(paul) → review+
(Assignee)

Comment 13

4 years ago
try: https://tbpl.mozilla.org/?tree=Try&rev=bbdbdc969753
No such failure in 100 runs.
(Assignee)

Comment 14

4 years ago
Hi Ryan,
Please check in part1_pushPrefEnv-v1.patch and leave this bug open. Thanks.
Keywords: checkin-needed
Whiteboard: [leave open]
(Assignee)

Updated

4 years ago
Blocks: 1022453
(Assignee)

Comment 17

3 years ago
Looks like it is fixed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [leave open]
status-firefox37: --- → unaffected
status-firefox38: --- → fixed
status-firefox-esr31: --- → unaffected
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.