Closed Bug 964771 Opened 9 years ago Closed 9 years ago

Add GA Event for Thimble Publish

Categories

(Webmaker Graveyard :: Thimble, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: humph, Assigned: humph)

References

Details

(Whiteboard: [workweek][workweek-metrics])

Attachments

(1 file)

We want to start experimenting with GA Events, and are going to use Thimble as a test case to figure out the process.
Depends on: 964893
Assignee: nobody → david.humphrey
Status: NEW → ASSIGNED
Blocks: 962753
Whiteboard: [workweek][workweek-metrics]
This adds GA Event tracking to Thimble using our shiny new webmaker-analytics module.

Adam, see if you're happy with the event name.  Also, do you care about success vs. failure cases (e.g., do you want me to log an event for publish-error)?

Pomax, is this the best place to log the event?
Attachment #8368576 - Flags: review?(pomax)
Attachment #8368576 - Flags: review?(adam)
Comment on attachment 8368576 [details] [review]
https://github.com/mozilla/thimble.webmaker.org/pull/348

looks fine to me, let's give this a shot.
Attachment #8368576 - Flags: review?(pomax) → review+
Humph, that looks great.

If we can add tracking to publish-error, that gives us a good example of a nonInteraction event to showcase next week:

e.g. 
analytics.event("Error", {label: "Error Publishing", nonInteraction: true});
Attachment #8368576 - Flags: review?(adam) → review+
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Adam, I've built this code on our staging infrastructure (thimble.mofostaging.net) and just published something.  Can you confirm that you get the "Publish" event for "thimble.mofostaging.net"?

If you did, I can push this up to production.
Flags: needinfo?(adam)
No luck yet because of the way GA data works...

I can see the Events being recorded in real-time if I'm looking at the dashboard straight away.

Otherwise they take 24 hours to be processed into the main reports.

I tried to do a publish myself from test staging site just now, but nothing happens if I click login, which means I can't get to the publish button. I'm online for a bit and happy to keep an eye on the real-time reports if anyone can click the publish button on staging? :)
Flags: needinfo?(adam)
Good news, these events have already made it through to the main reports so I can confirm they are being recorded correctly.

It's ready to go.

Thanks! :)
You need to log in before you can comment on or make changes to this bug.