Closed Bug 964826 Opened 6 years ago Closed 3 years ago

Menu is greyed out and unavailable while playing flash content on 4.4 KitKat

Categories

(Firefox for Android :: Toolbar, defect, major)

All
Android
defect
Not set
major

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox26 --- wontfix
firefox27 + wontfix
firefox28 - wontfix
firefox29 --- wontfix
firefox31 --- wontfix
firefox32 --- affected
firefox33 --- affected
firefox34 --- affected
fennec - ---

People

(Reporter: u421692, Assigned: snorp)

References

()

Details

Attachments

(1 file)

Attached image screenshot
Environment:
Device: LG Nexus 4(Android 4.4)
Build: Firefox Beta 27 Beta 10

Steps to reproduce:
1. Play flash content(e.g. intel museum of me)
2, Open Settings menu, and tap on any setting entry(e.g. Customize)

Expected result:
The menu is available and can be accessed.

Actual result:
Menu is greyed out and unavailable
I think this is likely some variation of the hang described in bug 957694.
I can reproduce this and the stack trace is identical to bug 957694. The difference here, though, is that we can recover once the compositor is enabled. Ugh. Need to think about what we can do here, if anything.

#0  0x400e1904 in __futex_syscall3 () from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libc.so
#1  0x400ceec8 in __pthread_cond_timedwait_relative () from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libc.so
#2  0x400cef28 in __pthread_cond_timedwait () from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libc.so
#3  0x403075f0 in android::BufferQueue::dequeueBuffer(int*, android::sp<android::Fence>*, bool, unsigned int, unsigned int, unsigned int, unsigned int) ()
   from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libgui.so
#4  0x4031057c in android::Surface::dequeueBuffer(ANativeWindowBuffer**, int*) () from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libgui.so
#5  0x40310b9a in android::Surface::lock(ANativeWindow_Buffer*, ARect*) () from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libgui.so
#6  0x40310336 in android::Surface::dispatchLock(std::__va_list) () from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libgui.so
#7  0x4030fc50 in android::Surface::hook_perform(ANativeWindow*, int, ...) () from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libgui.so
#8  0x73186180 in ANativeWindow_lock () from /Users/snorp/source/jimdb/lib/00850937d791b9ee/system/lib/libandroid.so
#9  0x842ea692 in ?? ()
#10 0x842ea692 in ?? ()
I guess I shouldn't say the stack is identical, because 957694 has GL involved, which added an extra wrinkle.
tracking-fennec: --- → ?
I reproduced this on a Galaxy Nexus Android 4.3 Firefox 26. I think this makes this a non-emergency.
(In reply to Kevin Brosnan [:kbrosnan] from comment #4)
> I reproduced this on a Galaxy Nexus Android 4.3 Firefox 26. I think this
> makes this a non-emergency.

Fascinating. I'll look into it some more, but agree it's not an emergency.
Discussed this in channel meeting, given QA investigation we decided not to block Fx27 on this and since we have already gone-to-build, not much we can there now.

But given we have STR I am tracking it for Fx28 as well to uplift a solution to resolve this issue.
(In reply to Kevin Brosnan [:kbrosnan] from comment #4)
> I reproduced this on a Galaxy Nexus Android 4.3 Firefox 26. I think this
> makes this a non-emergency.

I've checked also on Samsung Galaxy Nexus(Android 4.3) on FF26, but I was not able to reproduce this issue.
Assignee: nobody → snorp
tracking-fennec: ? → 27+
Status: NEW → ASSIGNED
This goes back at least a couple of releases and is not widely reproducible from what I see here, so not tracking but will consider a low risk uplift if one is available.
Snorp, is this a dupe of your nexus 7 hang?
tracking-fennec: 27+ → -
Flags: needinfo?(snorp)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #9)
> Snorp, is this a dupe of your nexus 7 hang?

It's similar, but not exactly the same. We can recover from this by resuming the compositor. The Nexus 7 one is a deadlock.
Flags: needinfo?(snorp)
Are we still tracking this issue?
tracking-fennec: - → ?
(In reply to Mihai Pop from comment #11)
> Are we still tracking this issue?

no, that's why it was a tracking-
tracking-fennec: ? → -
Flash is going away (bug 1381916), so there's no point in pursuing this further.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.