Email App has checkboarding and blanking while scrolling

RESOLVED DUPLICATE of bug 986699

Status

Firefox OS
Gaia::E-Mail
P1
major
RESOLVED DUPLICATE of bug 986699
4 years ago
4 years ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

({perf})

unspecified
2.0 S1 (9may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c=handeye p= s=2014.05.09.tracking u=])

Attachments

(5 attachments, 1 obsolete attachment)

(Assignee)

Description

4 years ago
See https://bugzilla.mozilla.org/show_bug.cgi?id=950733#c36, eliminate the blanking while scrolling.
(Assignee)

Comment 1

4 years ago
Created attachment 8367006 [details]
RenderTrace showing checker boarding
(Assignee)

Comment 3

4 years ago
Just checked with the reflow counters, we're not reflowing while scrolling.
(Assignee)

Comment 4

4 years ago
Created attachment 8367014 [details]
Another profile w/o the Compositor thread.
(Assignee)

Comment 5

4 years ago
Created attachment 8367021 [details]
Layer Tree While Scrolling
(Assignee)

Comment 6

4 years ago
Profile shows we have a 17ms gralloc allocation, so might be the same thing as bug 939348.
(Assignee)

Comment 7

4 years ago
Large amounts of the APZ scrolling code is being rewritten as stated in comment https://bugzilla.mozilla.org/show_bug.cgi?id=942750#c28. Will dig into checker boarding problems once bug 942750 and bug 957668 is fixed.
(Assignee)

Updated

4 years ago
Depends on: 942750, 957668

Updated

4 years ago
Whiteboard: [c=handeye p=5 s= u=1.3] → [c=handeye p=5 s= u=]
(Assignee)

Comment 9

4 years ago
Created attachment 8379107 [details]
email.mov

Looks like we aren't over painting very much either.
(Assignee)

Updated

4 years ago
Depends on: 959782
(Assignee)

Comment 10

4 years ago
10:13:06.377 reflow: 0.22ms function MessageListCard.prototype.messages_splice, mail_app.js line 5687
10:13:06.377 reflow: 10.23ms function MessageListCard.prototype.messages_splice, mail_app.js line 5687
10:13:07.471 reflow: 0.26ms function MessageListCard.prototype.messages_splice, mail_app.js line 5735
10:13:07.472 reflow: 6.03ms function MessageListCard.prototype.messages_splice, mail_app.js line 5735
(Assignee)

Comment 11

4 years ago
Whoops, noticed that we generally only checkerboard when we reflow from comment 10. Looking into reflows now.
(Assignee)

Updated

4 years ago
Depends on: 862872

Updated

4 years ago
Depends on: 796474

Updated

4 years ago
No longer depends on: 959782
(Assignee)

Comment 12

4 years ago
https://people.mozilla.org/~bgirard/cleopatra/#report=41cde46b99436a94ce9ae1439c76cae7f32cc880

Profile with tiling enabled. It's harder to checkerboard, but when we do, it's usually from a large layout::Flush following a requestSnippets in the email app. This causes some large grallocs. We have a ~200ms gralloc in this profile, which causes some checkerboarding.
(Assignee)

Updated

4 years ago
See Also: → bug 986699
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 986699

Updated

4 years ago
Whiteboard: [c=handeye p=5 s= u=] → [c=handeye p= s=2014.05.09.tracking u=]

Updated

4 years ago
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.