Closed Bug 965150 Opened 9 years ago Closed 9 years ago

jsreflect.cpp throws "InternalError: bad parse node" for valid js code

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 963641

People

(Reporter: vporof, Unassigned)

References

Details

The following code:

var foo = {};
var bar = {};

foo.prototype = {
  __proto__: bar
};

makes jsreflect.cpp throw a JSMSG_BAD_PARSE_NODE.
Blocks: 965147
It seems that ASTSerializer::property wants to match the "__proto__: bar" parse node as a JSOP_INITPROP, JSOP_INITPROP_GETTER or JSOP_INITPROP_SETTER, but the node is actually null, so it fails the assertion with a LOCAL_NOT_REACHED.
CC-ing some people who might know something about this. My experience with the reflection API is very limited.
This is probably a duplicate of bug 963641.
Yes it is.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.