[B2G][Helix] BGRA/RGBA colors intermittently swapped using HWC

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: justindarc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8367472 [details]
photo.JPG

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.102 Safari/537.36

Steps to reproduce:

Enable HWC (default) in Settings app.


Actual results:

Color channels appeared swapped intermittently. Immediately following a transition/animation, the colors appear correct for a brief moment, then return back to swapped. The colors appear correct when HWC is disabled.


Expected results:

Colors should appear correct with HWC enabled.
This looks a lot like bug 961059. Could you go through the steps there and check if this fixes the problem? Thanks.
(Reporter)

Comment 2

5 years ago
Yes, disabling HWC resolves the flipped colors. However, HWC is enabled by default on Helix. Shouldn't HWC be available on the Helix?
I don't know about the Helix. HWC was enabled by default on my Unagi until I cleaned* up the gaia directory and rebuild from scratch. All the old config settings were gone and HWC was not default anymore.

* git clean -xfd
Two things:

a. As per bug 947504 HWC should be disabled by default if the device doesn't support it.

b. The vendor build for Helix should have a patch to support rb swap [1]. 

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=947504#c11

Comment 5

2 years ago
Closing all intermittent test failures for Firefox OS (since we're not focusing on it anymore).

Please reopen if my search included your bug by mistake.

Comment 6

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.