crash in application.zip@0x1a1ffe

RESOLVED DUPLICATE of bug 948326

Status

()

Core
Audio/Video
--
critical
RESOLVED DUPLICATE of bug 948326
4 years ago
4 years ago

People

(Reporter: pfield, Unassigned)

Tracking

({crash, regression})

28 Branch
ARM
Gonk (Firefox OS)
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dogfood1.3 [b2g-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-23795fb0-6fdd-4ee5-b8c8-b5a922140129.
=============================================================

Description: 
A crash can occur if the user attempts to skip through a very long song on SoundCloud.com.

Repro Steps:
1) Updated Buri to Build ID: 20140127004002
2) tap to open Browser app.
3) Use the search bar to navigate to Soundcloud.com
4) Search for a long song that has a run time of over 1 hour.
5) Play the song and attempt to skip around to various points in the song.

Actual:
A crash may occur.

Expected:
User is able to skip through a song without a crash occurring.

Environmental Variables
Device: Buri v 1.3.0 Mozilla
Build ID: 20140127004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/c40099a42c1f
Gaia: 25a45a836a4a21a30f63fa7b544b42e8b781180a
Platform Version: 28.0a2
Firmware Version: V1.2-device.cfg
(Reporter)

Comment 1

4 years ago
Created attachment 8367485 [details]
crash-log.txt

Adding logcat

Updated

4 years ago
blocking-b2g: --- → 1.3?
Component: Gaia::Browser → Video/Audio
Keywords: regression, reproducible
Product: Firefox OS → Core
Whiteboard: dogfood1.3 → dogfood1.3 [b2g-crash]
Version: unspecified → 28 Branch
Can you give an example of a song that runs over an hour?
Flags: needinfo?(pfield)
(Reporter)

Comment 3

4 years ago
Yeah certainly Jsmith! A song that I used to get this issue is "Bearly Legal" by -The White Panda.-
Flags: needinfo?(pfield)
(Reporter)

Comment 4

4 years ago
I should clarify, I used this song in a playlist that connected with other songs and made for a very long "set of songs" but you can shift between all of them in the same time bar. But, you can also use a song that is over 1 hour and that will also trigger the issue, such as "https://soundcloud.com/jimanoli1/power-hour-classics" which is one long song and not many in a stream.
QA Wanted - Can we check what happens on 1.1 & 1.2?
Keywords: regression → qawanted
QA Contact: pbylenga
This issue does not reproduce on v1.2 or v1.1, user is able to seek around a long song without encountering a crash.  Tested the 'power-hour-classics' link in Comment 4.

v1.2 Environmental Variables:
Device: Buri v1.2 MOZ
BuildID: 20140130004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: f9f469d5d1e1
Version: 26.0
Firmware Version: v1.2-device.cfg

v1.1 Environmental Variables:
Device: Buri v1.1 MOZ
BuildID: 20140130041201
Gaia: c434fe9a0e823029796805e141cfa983cda2d246
Gecko: 1b24a4178317
Version: 18.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted → regression, regressionwindow-wanted
Upon further investigation this issue is not 100% reproducible.  It's closer to 10% but once it reproduces it'll reproduce often and can happen quickly.  Other times I've repeated the STRs for 10 minutes until I saw the crash. Restarting the device doesn't permanently fix it either, eventually it'll reproduce again.  I was able to reproduce it as early as 1-20-2014.  At this point in time it's unrealistic to grab a regression window that I'm confident upon.
Keywords: regressionwindow-wanted
(In reply to Peter Bylenga from comment #7)
> Upon further investigation this issue is not 100% reproducible.  It's closer
> to 10% but once it reproduces it'll reproduce often and can happen quickly. 
> Other times I've repeated the STRs for 10 minutes until I saw the crash.
> Restarting the device doesn't permanently fix it either, eventually it'll
> reproduce again.  I was able to reproduce it as early as 1-20-2014.  At this
> point in time it's unrealistic to grab a regression window that I'm
> confident upon.

Does this reproduce with shorter songs on soundcloud? Like 3 - 5 minutes in length.
Keywords: reproducible → qawanted
I've tried multiple songs within that length on the Build ID: 20140127004002 stated in Comment 0.  Have not encountered the crash, also discussed with the reporter offline and he had went through a lot of regular songs on that day without encountering the issue as well.
Keywords: qawanted
Given the low reproduction rate & low likelihood of hitting this crash, I'm going to pull the nom. However, I'd like to get technical input on whether this can happen elsewhere & how likely, as this could be possible to happen elsewhere.

Sotaro - Can you weigh in what's not working here & indicate how likely this could happen in the web?
blocking-b2g: 1.3? → ---
Flags: needinfo?(sotaro.ikeda.g)

Updated

4 years ago
Blocks: 927884
From the debugging, I confirmed that the crash happens when "mSamplesPerSecond == 0". It is a dup of Bug 918135. The bug is committed only to master, not to v1.3.
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Sotaro Ikeda [:sotaro] from comment #11)
> From the debugging, I confirmed that the crash happens when
> "mSamplesPerSecond == 0". It is a dup of Bug 918135. The bug is committed
> only to master, not to v1.3.

Sorry, the above was incorrect. The problem was already fixed by Bug 922334. But it is degraded by Bug 918135.
(In reply to Sotaro Ikeda [:sotaro] from comment #12)
> (In reply to Sotaro Ikeda [:sotaro] from comment #11)
> > From the debugging, I confirmed that the crash happens when
> > "mSamplesPerSecond == 0". It is a dup of Bug 918135. The bug is committed
> > only to master, not to v1.3.
> 
> Sorry, the above was incorrect. The problem was already fixed by Bug 922334.
> But it is degraded by Bug 918135.

After that the regression is fixed by Bug 948326. But it is only on master, not v1.3.
Just to clarify - so bug 948326 is what we need here, right?
Flags: needinfo?(sotaro.ikeda.g)
(In reply to Jason Smith [:jsmith] from comment #14)
> Just to clarify - so bug 948326 is what we need here, right?

Yes. Need to uplift to v1.3.
Flags: needinfo?(sotaro.ikeda.g)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 948326

Updated

4 years ago
No longer blocks: 927884
You need to log in before you can comment on or make changes to this bug.