Closed Bug 965434 Opened 6 years ago Closed 4 years ago

[B2G][Gaia][Homescreen] The homescreen can become stuck scrolling to one side after moving app icons.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3 --- affected

People

(Reporter: lmauritson, Unassigned)

References

()

Details

(Whiteboard: dogfood1.3)

Attachments

(1 file)

Description:
If the user moves an app icon to the side and tries to scroll back while the icon is being placed the icon will move a page further and cause the homescreen to always scroll to that last page.

Repro Steps:
1) Update a Buri to BuildID: 20140127004002
2) On the homescreen select an app icon and move it a page to the right creating a new page
3) Back to the previous screen (left) and grab another icon
4) Drag the icon to the same page (on the right) as was created in step 2, but before the icon has fully placed, quickly swipe back to the left.

Timing is important:
The icon will move near the correct position and then snap to the correct coordinates. The scroll back must happen before the snap in order to reproduce this issue.


Actual:
The icon will move an additional page over creating a second new page.
Scrolling to the left will result in the homescreen back to the right.
Pressing the home button brings the user back to the main screen, but will bring them back to the last page one page at a time.
The icon causing the issue can be seen on both the last and second to last page after pressing home. 

Expected:
App icons place properly regardless of the scroll state of the UI.
The homescreen never scrolls automatically to one side.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140127004002
Gaia: 25a45a836a4a21a30f63fa7b544b42e8b781180a
Gecko: c40099a42c1f
Version: 28.0a2
Firmware Version: v1.2-device.cfg


Notes: Restarting the device appears to fix this.

Repro frequency: I can reproduce this about 50% of the time.

See attached: http://youtu.be/kpLbAAs_5DY
QA Wanted - What happens on 1.1?
Keywords: qawanted
QA Contact: pfield
Was not able to reproduce on this issue Buri V 1.1

Environmental Variables:
Device: buri 1.1 com
BuildID: 20140130041201
Gaia: c434fe9a0e823029796805e141cfa983cda2d246
Gecko: 1b24a4178317
Version: 18.0
RIL Version: 01.01.00.019.281
Keywords: qawanted
The confusion point I have in the above STR vs. the video is that the video is showing evidence of you holding down the home button during the execution of the STR. What happens if you aren't holding the home button?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #3)
> The confusion point I have in the above STR vs. the video is that the video
> is showing evidence of you holding down the home button during the execution
> of the STR. What happens if you aren't holding the home button?

Hey Jason, the video does indeed look like he is holding the home button down but that is just because of how the video was recorded. He actually wasn't touching it and the home button does not seem to influence this bug whatsoever.
Keywords: qawanted
Can we get a different video then showcasing the simplest STR to reproduce this bug?
Keywords: qawanted
I tried to narrow it down a bit and made a video from FTE to finish, as well as one where I managed it a lot quicker.
The links start where I get the issue but I recorded the whole process so you can get an idea of how frequently this may occur.
I will note that it is a bit harder to do while recording as I have to keep both devices still. (I must thank YouTube for auto stabilization)
1. http://youtu.be/KtysYLUnAjk?t=6m40s
2. http://youtu.be/MSbZJd557WU?t=3m12s

From this I have concluded that the following steps should produce the issue:

1. Move an app to the right to make a new page.
2. Move another app from the first (not e.me) page to the new one and all the way to the right as though attempting to make a third page, but then release and swipe back to the left before the new page is moved to.

The app must generally cause at least one screen change while being moved before the one where it creates a new page as that will ensure it is in the correct position for the user to swipe back at the same time as it tries to create a new page.

I'm not sure how relevant it is, but I pressed the home button between many attempts to get the icons back to their normal "still" state.
I also opened a few apps by accident, including the ones that got stuck.

I think what is happening is that the icon attempts to do two things at once, fully completing neither:
A) Snap to currently visible page
B) Move to the right and create a new page

I base this on the fact that the icon can often be visible on both pages. 
Also since the "move" part of the "move and create new page" action is interrupted it seems that it continues to try and complete this action indefinitely as nothing tells it it was successful.

I hope that helps!
Keywords: qawanted
If you end up in this situation, then can you recover from it? For example, does this continue to reproduce after you restart the device?
Keywords: qawanted
Restarting the device clears this issue completely. The app icon will make up its mind and pick one of the pages to stay on. 

Restarting does not prevent it from potentially happening again under the same circumstances.
Keywords: qawanted
(In reply to Lionel Mauritson from comment #8)
> Restarting the device clears this issue completely. The app icon will make
> up its mind and pick one of the pages to stay on. 
> 
> Restarting does not prevent it from potentially happening again under the
> same circumstances.

Okay - since it's recoverable, I don't think I'll put this on the blocking nomination list.
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.