Legacy sync link on about:accounts getting started page loads new link in same tab, losing the welcome screen

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Sync
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: pdehaan, Assigned: markh)

Tracking

unspecified
Firefox 30
Points:
---

Firefox Tracking Flags

(firefox29+ verified, firefox30 verified)

Details

(Whiteboard: [qa+])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
via https://github.com/mozilla/fxa-content-server/issues/354

Steps to reproduce:
1. Go to "about:accounts".
2. Click the "Using Sync on an older version of Nightly?" link at the bottom of the page.

Actual results:
The link currently works and redirects to https://support.mozilla.org/en-US/kb/how-sync-works-old-version-firefox?as=u&utm_source=inproduct but it loads the mozilla support page in the same tab, so I'm no longer on about:accounts.

Expected results:
add `target="_blank"` or something to the anchor tag so the Mozilla Support link opens in a new tab.
Whiteboard: [qa+]
Incidentally, this is the link we're using for Android.

https://support.mozilla.org/kb/use-sync-with-an-older-version-of-firefox

Should we switch?
(Assignee)

Comment 2

4 years ago
I thought it was a feature :)  John, can you confirm if this should replace about:accounts or open a new tab?  Change is trivial if that's what is wanted.
Flags: needinfo?(jgruen)

Comment 3

4 years ago
moving component
Component: Firefox Sync: UI → FxA
OS: Mac OS X → All
Product: Mozilla Services → Firefox
Hardware: x86 → All
Yeah, let's make this load in a new tab.
Flags: needinfo?(jgruen)

Updated

4 years ago
Whiteboard: [qa+] → p=0 [qa+]
(Assignee)

Comment 5

4 years ago
Created attachment 8375304 [details] [diff] [review]
Open sumo article in a tab
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Attachment #8375304 - Flags: review?(ttaubert)
Attachment #8375304 - Flags: review?(ttaubert) → review+
https://hg.mozilla.org/mozilla-central/rev/d34e01528ec9
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30

Updated

4 years ago
No longer blocks: 950073
Whiteboard: p=0 [qa+] → [qa+]
status-firefox29: --- → affected
tracking-firefox29: --- → +
(Assignee)

Comment 8

4 years ago
Comment on attachment 8375304 [details] [diff] [review]
Open sumo article in a tab

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Fxa Sync
User impact if declined: about:accounts tab will be replaced if the user wants to read information about legacy sync support.
Testing completed (on m-c, etc.): Landed on mc
Risk to taking this patch (and alternatives if risky): Low
String or IDL/UUID changes made by this patch: None
Attachment #8375304 - Flags: approval-mozilla-aurora?
status-firefox30: --- → fixed
Attachment #8375304 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.