Dragging icons into padding sometimes makes a bunch of other icons disappear

VERIFIED FIXED in Firefox 29

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: alice0775, Assigned: Gijs)

Tracking

(Blocks: 2 bugs)

29 Branch
Firefox 29
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P2])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 8367692 [details]
screenshot

See screenshot, some icons such as Find, Options and Developer are missing.
(Reporter)

Updated

5 years ago
Summary: Missing icon while customize → Missing icon while customize mode
(Assignee)

Updated

5 years ago
Blocks: 872617
Whiteboard: [Australis:P1]
Keywords: regressionwindow-wanted
(Reporter)

Comment 1

5 years ago
Steps To Reproduce:
1. Enter Customize mode
2. Drag a icon e.g. "New Window" icon
   And drop it on Blue border area quickly


Actual Results:
Some icons are gone

Regression window:
Good(No Australis):
http://hg.mozilla.org/mozilla-central/rev/beddd6d4bcdf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131118030203
Bad:
http://hg.mozilla.org/mozilla-central/rev/f2adb62d07eb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131118094134
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=beddd6d4bcdf&tochange=f2adb62d07eb

The problem is reproducble since UX marge day....
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

5 years ago
Created attachment 8367731 [details]
20140130_1009_00.swf

Screen capture
(Assignee)

Comment 3

5 years ago
I can reproduce this on OS X...
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Updated

5 years ago
Summary: Missing icon while customize mode → Dragging icons into padding sometimes makes a bunch of other icons disappear
(Assignee)

Comment 4

5 years ago
Created attachment 8367902 [details] [diff] [review]
dragexit should always reset dragoveritem in Australis' customize mode,

D'oh.
Attachment #8367902 - Flags: review?(mdeboer)
(Assignee)

Comment 5

5 years ago
(normally this case is caught by dragexit, but if you move the mouse really quickly it might not be, and so stuff ends up being perpetually transformed - this patch fixes it by ensuring dragend always resets the dragoveritem if necessary)
(Assignee)

Comment 6

5 years ago
Also, although this is serious, as soon as you exit customize mode, stuff is fine again, so I don't think it's P1 after all. :-)
Whiteboard: [Australis:P1] → [Australis:P2]
Attachment #8367902 - Flags: review?(mdeboer) → review+
(Assignee)

Comment 7

5 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/d5823c08b120
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
(Reporter)

Updated

5 years ago
Blocks: 939862
No longer blocks: 646359
https://hg.mozilla.org/mozilla-central/rev/d5823c08b120
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 29
Verified as fixed in Nightly (build ID: 20140226030202) and Aurora (build ID: 20140227004002).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.