JS Engine version-dependent keywords not maintained properly.

RESOLVED FIXED in mozilla0.9.4

Status

()

Core
JavaScript Engine
P1
normal
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Conrad Carlen (not reading bugmail), Assigned: brendan)

Tracking

({js1.5})

Trunk
mozilla0.9.4
x86
Windows 2000
js1.5
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: patch)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
This problem shows itself when going to http://home.netscape.com while using
turbo mode. This page sets the JS version to something lower than is needed to
deal with chrome, causing chrome JS to fail.
(Reporter)

Updated

17 years ago
Blocks: 86021
(Assignee)

Comment 1

17 years ago
The problem is that JSContext.scannerVersion should be in the JSRuntime.  What a
botch.  Easily fixed, patch coming up.

/be
Status: NEW → ASSIGNED
Keywords: js1.5, mozilla0.9.4
Priority: -- → P1
Target Milestone: --- → mozilla0.9.4
(Assignee)

Comment 2

17 years ago
Argh, it's harder than that.  Multi-threading screws my simple plan.  There is
in fact a problem with keyword reserved-ness being stored in the atom table,
shared among all JSContexts.  More in a bit, still trying for 0.9.4 to unblock
conrad's bug.

/be
QA Contact: pschwartau
Summary: JS Engine script version is not maintained properly.

Updated

17 years ago
Summary: JS Engine script version is not maintained properly.
Could this be causing bug 74539 as well?

Comment 4

17 years ago
*blink*

*blink*

Comment 5

17 years ago
Yeah, I think they're one and the same bug (at least the initial comment, dunno
about what follow-up stuff was commented in there).

Updated

17 years ago
Blocks: 74539
(Assignee)

Comment 6

17 years ago
Created attachment 46863 [details] [diff] [review]
proposed fix (diff -u, for applying)
(Assignee)

Comment 7

17 years ago
Created attachment 46864 [details] [diff] [review]
diff -wu version of patch, for reviewing
(Assignee)

Comment 8

17 years ago
Conrad, apply the first attachment in your mozilla/js/src directory and remake
there.  Let me know if this doesn't cure the symptom.  With this change, I pass
the JS testsuite and Mozilla runs fine.

Looking for r= and sr=.

/be
Whiteboard: patch
(Assignee)

Comment 9

17 years ago
Better summary.

/be
Summary: JS Engine script version is not maintained properly. → JS Engine version-dependent keywords not maintained properly.
(Reporter)

Comment 10

17 years ago
Alright - the patch works!

Comment 12

17 years ago
r=rogerl

(except after I patched jsscan.c, I saw 'indenting issues' at line #782).

Comment 13

17 years ago
It looks OK to me (though you already have your cookies :)

r=jband
(Assignee)

Comment 14

17 years ago
rogerl: did you apply the diff -u, or the diff -wu?  The former is for applying
via patch, the latter for reviewing.

Thanks all, going for approval.

/be
a=dbaron (on behalf of drivers)
(Assignee)

Comment 16

17 years ago
Fix checked in.

/be
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 17

17 years ago
*** Bug 74539 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.