[Linux] UITour: leaves the panel menu open above other applications with focus

VERIFIED FIXED in Firefox 29

Status

()

Firefox
General
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: karlt, Assigned: MattN)

Tracking

Trunk
Firefox 30
All
Linux
Points:
---

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P3-][fixed by bug 966072])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8368290 [details]
screenshot

1. Set the browser.uitour.whitelist.add.testing preference to www-demo3.allizom.org
2. Load https://www-demo3.allizom.org/b/en-US/firefox/australis/update/
3. Click "Learn more" under "Take the tour"

A door hanger drops down from a grey icon with 3 horizontal bars.

4. Open another application, attempt to move that application over the
browser, and focus the new application.

Expected results:

The new application is above all the browser windows, or temporary browser
windows close.  The door hanger should probably close on focus out.

Actual results:

The door hanger from the browser is above the new application.
(Reporter)

Updated

4 years ago
Blocks: 862998
(In reply to Karl Tomlinson (:karlt) from comment #0)
> The new application is above all the browser windows, or temporary browser
> windows close.  

I can probably just explicitly set @level="parent" on the panels since I think the issue is that Linux default to "top"[1]. Can you give that a try?

> The door hanger should probably close on focus out.
We intentionally don't close the menu by setting @noautohide but it shouldn't appear above other applications.

[1] https://developer.mozilla.org/en-US/docs/XUL/Attribute/panel.level
Summary: uitour leaves popup windows open above other applications with focus → [Linux] UITour: leaves the panel menu open above other applications with focus
(Reporter)

Comment 2

4 years ago
(In reply to Matthew N. [:MattN] from comment #1)
> I can probably just explicitly set @level="parent" on the panels since I
> think the issue is that Linux default to "top"[1]. Can you give that a try?

I can try a patch.  I wouldn't know where to add @level="parent".

Watch out for bug 835044.  If that gets in the way, I can create a new patch for that next week.  That is currently unused code, so it would need some testing.
(Reporter)

Comment 3

4 years ago
I tried toggling ui.panel.default_level_parent but it didn't change the behaviour reported in comment 0.
Priority: -- → P3
Hardware: x86_64 → All
Priority: P3 → --
Whiteboard: [Australis:P3-]

Comment 4

4 years ago
(In reply to Matthew N. [:MattN] from comment #1)
> (In reply to Karl Tomlinson (:karlt) from comment #0)
> > The new application is above all the browser windows, or temporary browser
> > windows close.  
> 
> I can probably just explicitly set @level="parent" on the panels since I
> think the issue is that Linux default to "top"[1]. Can you give that a try?
> 
> > The door hanger should probably close on focus out.
> We intentionally don't close the menu by setting @noautohide but it
> shouldn't appear above other applications.
> 
> [1] https://developer.mozilla.org/en-US/docs/XUL/Attribute/panel.level

Do we know why Linux defaults to level="top" and would overriding that default break other things?

Comment 5

4 years ago
Noautohide panels are at parent level by default.

But this should be fixed by bug 966072, no?

Comment 6

4 years ago
(In reply to Neil Deakin from comment #5)
> Noautohide panels are at parent level by default.
> 
> But this should be fixed by bug 966072, no?

Judging by stuff like bug 977125, it doesn't seem fixed...

Comment 7

4 years ago
Bug 977125 is not the same issue.

Comment 8

4 years ago
(In reply to Neil Deakin from comment #7)
> Bug 977125 is not the same issue.

Hrm, but I would have expected it to behave the same there... anyway, it does seem like this is fixed even if bug 977125 is still an issue. Also, I'm seeing weird graphics glitches when letting the tour open the panel which I'm not seeing when I open it myself... but I'll file another bug for that.
Assignee: nobody → MattN+bmo
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox29: --- → fixed
status-firefox30: --- → fixed
Resolution: --- → FIXED
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed by bug 966072]
Target Milestone: --- → Firefox 30
Verified as fixed using the following environment:

FF 29
Build id:20140305004002

FF 30
Buid id: 20140304030204

OS:Ubuntu 12.04 x86
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.