Closed Bug 966124 Opened 6 years ago Closed 6 years ago

focusing the "Manage" link in Sync preferences produces a weird huge focus outline

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: Gavin, Assigned: ttaubert)

References

Details

(Whiteboard: p=1 s=it-30c-29a-28b.2 [qa!])

Attachments

(2 files, 1 obsolete file)

Attached image screenshot
No description provided.
Whiteboard: p=0
Whiteboard: p=0 → p=0, [qa+]
Duplicate of this bug: 971721
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Attachment #8377494 - Flags: review?(mhammond)
Comment on attachment 8377494 [details] [diff] [review]
0001-Bug-966124-focusing-the-Manage-link-in-Sync-preferen.patch

Review of attachment 8377494 [details] [diff] [review]:
-----------------------------------------------------------------

Heh - flex caused me all kinds of grief - I'm not at all surprised there's an extra one causing problems :)
Attachment #8377494 - Flags: review?(mhammond) → review+
https://hg.mozilla.org/integration/fx-team/rev/3616e7f1523d
Whiteboard: p=0, [qa+] → p=0, [qa+][fixed-in-fx-team]
Hi Tim: it's a bug with bugzillajs. The links work, just copy and paste them.
Whiteboard: p=0, [qa+][fixed-in-fx-team] → p=1 s=it-30c-29a-28b.2 [qa+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/3616e7f1523d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: p=1 s=it-30c-29a-28b.2 [qa+][fixed-in-fx-team] → p=1 s=it-30c-29a-28b.2 [qa+]
Target Milestone: --- → Firefox 30
Keywords: verifyme
QA Contact: twalker
verified fixed with nightly build of 20140219
Status: RESOLVED → VERIFIED
Bizarre. This appeared to be fine on first look.  Revisiting it, it is still broken with the large blue square. oh hmmm, the square goes away if the prefs window isn't focused.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Marco, I reopened this.  Should I be pinging you or the dev?
Flags: needinfo?(mmucci)
Hi Tracy, if you find a defect then it should be reopened.  When that happens you can just ping the developer to continue working on it.
Flags: needinfo?(mmucci)
Thanks Chris.  Over to you, Tim.
Flags: needinfo?(ttaubert)
Yeah, my patch didn't fix anything, sorry. Working on it.
Flags: needinfo?(ttaubert)
Remove the button margin on OSX that pushed the button down and misaligned it. Linux and Windows doesn't seem to need that.
Attachment #8377494 - Attachment is obsolete: true
Attachment #8379564 - Flags: review?(mhammond)
Attachment #8379564 - Flags: review?(mhammond) → review+
https://hg.mozilla.org/integration/fx-team/rev/24adaa318267
Whiteboard: p=1 s=it-30c-29a-28b.2 [qa+] → p=1 s=it-30c-29a-28b.2 [qa+][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/24adaa318267
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: p=1 s=it-30c-29a-28b.2 [qa+][fixed-in-fx-team] → p=1 s=it-30c-29a-28b.2 [qa+]
Verified fixed, this time with prefs window focused, on Nightly build of 20140224.

will this be uplifted to Aurora?
Status: RESOLVED → VERIFIED
Comment on attachment 8379564 [details] [diff] [review]
0001-Bug-966124-focusing-the-Manage-link-in-Sync-preferen.patch, v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): FxA Sync 
User impact if declined: Weird focus outline in prefs pane.
Testing completed (on m-c, etc.): Verified fixed on m-c
Risk to taking this patch (and alternatives if risky):  Low risk
String or IDL/UUID changes made by this patch: None
Attachment #8379564 - Flags: approval-mozilla-aurora?
Attachment #8379564 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Whiteboard: p=1 s=it-30c-29a-28b.2 [qa+] → p=1 s=it-30c-29a-28b.2 [qa!]
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
You need to log in before you can comment on or make changes to this bug.