Inspector's autocomplete popup remains open over tab switches

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Inspector
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: petruta, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Reproducible on:
Fx 27RC (BuildID: 20140127194636)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
latest Aurora (BuildID: 20140131004003)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
latest Nightly (BuildID: 20140130030202)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Steps to reproduce:
1. Open http://www.mozilla.org/en-US/
2. Select Tools -> Web Developer -> Inspector (or Ctrl+Shift+C)
3. On the Rules tab trigger an auto-completion pop-up (eg: back) 
4. Open a new tab using Ctrl/Cmd+T

Expected results: 
The pop-up is closed when a new tab is opened.

Actual results: 
The pop-up remains opened in the newly opened tab.

Notes:
1. This issue is not a regression.
2. Reproducible also on Mac OSX 10.8.5 and Ubuntu 32-bit.
Going through the steps from comment 0 I can't reproduce the bug. When I hit Cmd+T the devtools are not opened on the new tab ( hence, the autocomplete pop-up is not shown).
Can you tell me if you're still able to reproduce the bug ? Thanks !
Flags: needinfo?(petruta.rasa)
(Reporter)

Comment 2

2 years ago
The devtools weren't opened at the time this bug was filled, the autocomplete pop-up remained opened in a new tab by himself.

This behavior doesn't reproduce on newer versions, so I'm  marking this as RWFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(petruta.rasa)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.