"News" page at bbc.co.uk never finishes loading in Metro Firefox

VERIFIED WORKSFORME

Status

Firefox for Metro
Browser
P1
normal
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

(Blocks: 1 bug, {qawanted, testcase-wanted})

28 Branch
x86_64
Windows 8.1
qawanted, testcase-wanted
Dependency tree / graph

Firefox Tracking Flags

(firefox28 affected, firefox29 affected)

Details

(Whiteboard: p=5 s=it-30c-29a-28b.3 r=ff29 [qa-], URL)

(Assignee)

Description

4 years ago
This issue was originally reported at https://support.mozilla.org/en-US/questions/984976

Steps to reproduce:
1) In Metro Firefox, open http://www.bbc.co.uk/news/

Results: The content never displays, and the progress bar remains about 75% full forever.

The console shows nothing except a bunch of network activity.  A bunch of scripts and images are downloaded, but nothing is displayed.  The DOM inspector shows an HTML document with an empty <head> element and no <body>.

A reduced test case might be useful here.

Updated

4 years ago
Whiteboard: [defect] [triage] p=0 → [release28] [defect] p=0
(Assignee)

Updated

4 years ago
Assignee: nobody → mbrubeck
Whiteboard: [release28] [defect] p=0 → [release28] [defect] p=5

Comment 1

4 years ago
dev tools shows zero js and network errors, with all of gets succeeding.

Comment 2

4 years ago
disabling omtc and apzc doesn't help. also I attached a debugger to the browser looking for chrome js errors, didn't see anything. odd bug.

Updated

4 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
QA Contact: jbecerra
Whiteboard: [release28] [defect] p=5 → [release28] [defect] p=5 s=it-30c-29a-28b.1

Updated

4 years ago
Target Milestone: --- → Firefox 28
(Assignee)

Comment 3

4 years ago
I wasn't able reproduce this bug with a saved static copy of the page.  I did notice that the static copy displays a Flash ad, then eventually replaces the Flash ad with the page content.  Perhaps some script on the page is failing in Metro because plugins are disabled.

Updated

4 years ago
Whiteboard: [release28] [defect] p=5 s=it-30c-29a-28b.1 → [release28] p=5 s=it-30c-29a-28b.1 r=ff28
Target Milestone: Firefox 28 → ---
Same problem at http://www.bbc.co.uk/news/world-asia-india-26028381 btw. Progress indicator shows we get 3/4 of the way through loading and it just stops.

Updated

4 years ago
Whiteboard: [release28] p=5 s=it-30c-29a-28b.1 r=ff28 → [release28] p=5 r=ff28

Updated

4 years ago
QA Contact: jbecerra → kamiljoz
Whiteboard: [release28] p=5 r=ff28 → [release28] p=5 s=it-30c-29a-28b.2 r=ff28

Updated

4 years ago
Whiteboard: [release28] p=5 s=it-30c-29a-28b.2 r=ff28 → [release28] p=5 s=it-30c-29a-28b.3 r=ff28
Matt & Sam,

Can you guys reproduce this with the latest Nightly build? I tried reproducing the issue using both sites from comment #0 and comment #4 and couldn't reproduce the problem. Both websites loaded and the progress indicator disappeared once the entire website was finished loadeding. I tested it on both the Surface Pro 2 and the X1 Carbon.

Used the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-01-03-02-04-mozilla-central/

Comment 6

4 years ago
still seeing this on latest mc tip.
We can put this in the "known issues" section for FF28 release notes as it will not be resolved before shipping (if anyone can confirm if this is in touch mode only or both, please do).
relnote-firefox: --- → ?
QAwanted for comment 7 - can you help confirm if this reproduces in both modes?
Keywords: qawanted

Comment 9

4 years ago
This is touch mode only
Removing release blocking tags and tagging for a FF29 release based on Comment #7.
Blocks: 861680
No longer blocks: 838081
Whiteboard: [release28] p=5 s=it-30c-29a-28b.3 r=ff28 → p=5 s=it-30c-29a-28b.3 r=ff29
I still can't reproduce this issue on my end. I used the Surface Pro 2 and used touch only and than tried with the keyboard attached and still couldn't reproduce. Both links from comment #0 and comment #4 loaded without any problems. I used the following builds:

- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-06-03-02-01-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-03-06-00-40-01-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/28.0b8/win32/en-US/

Juan, could you be able to see if you can reproduce this on your end?
Blocks: 838081
No longer blocks: 861680
Flags: needinfo?(jbecerra)
Whiteboard: p=5 s=it-30c-29a-28b.3 r=ff29 → [release28] p=5 s=it-30c-29a-28b.3 r=ff28
Blocks: 861680
No longer blocks: 838081
Whiteboard: [release28] p=5 s=it-30c-29a-28b.3 r=ff28 → p=5 s=it-30c-29a-28b.3 r=ff29
I haven't been able to reproduce this on a Surface Pro 2 or Acer Iconia W3 using the latest beta or nightly. Content loads pretty quickly on the Surface Pro 2 and the progress bar goes to 100% almost immediately. On the Acer tablet content also loaded right away but the progress bar took a little longer to go 100%.

I didn't check on aurora builds.
Flags: needinfo?(jbecerra)
Using the builds from comment #11, I tried loading the websites on the X1 Carbon without any luck. Also tried it on my main desktop at home and both websites are loading pretty quickly without issues.

Comment 14

4 years ago
I reinstalled latest beta and AM also unable to replicate now. Page loaded correctly in touch and desktop modes.
Hey Matt, based on the latest comments (11, 12, 13, 14) can you confirm if this can be marked as 'Resolved'
Flags: needinfo?(mbrubeck)
(Assignee)

Comment 16

4 years ago
Yes, looks like this is fixed - probably by a change on the BBC end.  I'm not sure whether the original problem was a bug in Firefox or in the BBC code, but we no longer have a test case that reproduces it so I am resolving this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mbrubeck)
Resolution: --- → WORKSFORME

Updated

4 years ago
Status: RESOLVED → VERIFIED
Whiteboard: p=5 s=it-30c-29a-28b.3 r=ff29 → p=5 s=it-30c-29a-28b.3 r=ff29 [qa-]
relnote-firefox: ? → ---
You need to log in before you can comment on or make changes to this bug.