Closed Bug 966480 Opened 6 years ago Closed 4 years ago

screen.mozLockOrientation did not work on a Nexus 4 device.

Categories

(Firefox for Android :: Web Apps (PWAs), defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jujjyl, Unassigned)

References

Details

(Whiteboard: [games])

Steps to reproduce:

1. With a Nexus 4 Android phone running Firefox Nightly, navigate to https://dl.dropboxusercontent.com/u/40949268/Bugs/screen_lock_orientation_bug.html
2. Rotate the phone to landscape/portrait orientations.

Observed: The browser page orientates freely according to the orientation the device is held in.

Expected: The browser page is locked to landscape-primary orientation and turning the device will not rotate the page.

Notes:

 - The code follows this source https://developer.mozilla.org/en-US/docs/Web/API/Screen.lockOrientation to lock the orientation to landscape-primary orientation.

 - Another Emscripten-based page that exhibits the problem is available at https://dl.dropboxusercontent.com/u/40949268/Bugs/emscripten_lock_orientation/a.html

 - Emscripten currently implements a C -> JS interface to locking orientation, which can be reviewed here: https://github.com/kripken/emscripten/blob/master/src/library_html5.js#L977
Whiteboard: [games]
Component: DOM: Core & HTML → Web Apps
Product: Core → Firefox for Android
QA Contact: aaron.train
Version: 29 Branch → unspecified
I have tested my own demo on my Android device and it seems that screen.mozLockOrientation() fails to perform its job.

View this demo in Firefox on Android: http://jsbin.com/heheri/quiet

Clicking on “Lock to landscape” executes this code: 

    screen.mozLockOrientation('landscape')

and alerts its return value. Notice how attempting to lock orientation while not in fullscreen mode alerts “false”, which is ok. However, after entering fullscreen mode (via supplied button), and then pressing the “Lock to landscape” button, the return value is “true” but the orientation isn’t locked as rotating the device toggles portrait/landscape as before.
Per bug 1235869, we're going to disable the Android web runtime, so we won't fix this bug in it.

(This is part of a bulk resolution of bugs in the Firefox for Android::Web Apps component, from which I attempted to exclude bugs that are not specific to the runtime, but it's possible that I included one accidentally.  If so, I'm sorry, and please reopen the bug!)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.