Closed Bug 966489 Opened 6 years ago Closed 6 years ago

Google Phone Search listing displays browser package name

Categories

(Firefox for Android :: General, defect)

29 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
fennec + ---

People

(Reporter: aaronmt, Assigned: jdover)

Details

(Keywords: polish)

Attachments

(2 files)

Attached image screenshot.png
See screenshot.

Anyone else see them as package names?
This was from a Galaxy SII (Android 4.2)
Keywords: polish
Summary: Phone search listing displays package name → Google Phone Search listing displays browsere package name
Summary: Google Phone Search listing displays browsere package name → Google Phone Search listing displays browser package name
Same on Gingerbread
(In reply to Mark Finkle (:mfinkle) from comment #2)
> Same on Gingerbread

I lied. Gingerbread is fine.

Android 4.3 shows the package names
tracking-fennec: --- → ?
Assignee: nobody → jdover
tracking-fennec: ? → +
Looks like it was probably a regression caused by bug 923519. According to Android's docs, the *value* for android:label on searchable.xml must match the activity and application labels, thus they must be pointing to the same string resource.
Attachment #8375973 - Flags: review?(bnicholson)
Status: NEW → ASSIGNED
Comment on attachment 8375973 [details] [diff] [review]
Use string resource for display name to match searchable

Assuming you tested this and verified the fix already. Both @MOZ_APP_DISPLAYNAME@ and @string/moz_app_displayname should evaluate to the same string, so that's pretty obnoxious that Android is this strict. Nice find!
Attachment #8375973 - Flags: review?(bnicholson) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/db83824a62a7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
You need to log in before you can comment on or make changes to this bug.