TestGtkEmbed chokes on some urls

VERIFIED DUPLICATE of bug 96440

Status

Core Graveyard
Embedding: GTK Widget
--
blocker
VERIFIED DUPLICATE of bug 96440
17 years ago
6 years ago

People

(Reporter: Curt Patrick (gone), Assigned: blizzard)

Tracking

({crash, smoketest})

Trunk
x86
Linux
crash, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
As of yesterday morning's builds, TestGtkEmbed crashes with a Segmentation Fault
error on at least the following two urls:

http://jrgm.mcom.com/perf/loadtime5/base/www.zdnet.co.jp_eweek/index.html
http://jrgm.mcom.com/perf/loadtime5/base/www.ttimes.com.tw/index.html

Comment 1

17 years ago
adding smoketest keyword (actually blocking performance testing)
Keywords: smoketest

Comment 2

17 years ago
A backtrace from a crash on http://www.zdnet.co.jp/eweek/index.html:

#0  0x4119b5c8 in HTMLContentSink::ProcessHeaderData (this=0x42503800,
    aHeader=0x819d5e8, aValue=@0xbfffe9d8, aContent=0x85c9b48)
    at nsHTMLContentSink.cpp:4659
#1  0x4119a95f in HTMLContentSink::ProcessMETATag (this=0x42503800,
    aNode=@0x425316e0) at nsHTMLContentSink.cpp:4551
#2  0x41195f31 in HTMLContentSink::AddLeaf (this=0x42503800, aNode=@0x425316e0)
    at nsHTMLContentSink.cpp:3423
#3  0x40c6b0d5 in CNavDTD::AddLeaf (this=0x425314f8, aNode=0x425316e0)
    at CNavDTD.cpp:3754
#4  0x40c6b2bd in CNavDTD::AddHeadLeaf (this=0x425314f8, aNode=0x425316e0)
    at CNavDTD.cpp:3812
#5  0x40c66e2d in CNavDTD::HandleStartToken (this=0x425314f8,
    aToken=0x4252dfe0) at CNavDTD.cpp:1699
#6  0x40c64f1d in CNavDTD::HandleToken (this=0x425314f8, aToken=0x4252dfe0,
    aParser=0x4250c328) at CNavDTD.cpp:870
#7  0x40c63f06 in CNavDTD::BuildModel (this=0x425314f8, aParser=0x4250c328,
    aTokenizer=0x42532318, anObserver=0x0, aSink=0x42503800) at CNavDTD.cpp:506
#8  0x40c78bb2 in nsParser::BuildModel (this=0x4250c328) at nsParser.cpp:2218
#9  0x40c78867 in nsParser::ResumeParse (this=0x4250c328, allowIteration=1,
    aIsFinalChunk=0) at nsParser.cpp:2084
#10 0x40c7a3f3 in nsParser::OnDataAvailable (this=0x4250c328,
    request=0x4251c7b0, aContext=0x0, pIStream=0x42295730, sourceOffset=0,
    aLength=384) at nsParser.cpp:2689
#11 0x40d11ff3 in nsDocumentOpenInfo::OnDataAvailable (this=0x42227f60,
    request=0x4251c7b0, aCtxt=0x0, inStr=0x42295730, sourceOffset=0, count=384)
    at nsURILoader.cpp:241
#12 0x40b4d83e in nsStreamListenerTee::OnDataAvailable (this=0x4224a978,
    request=0x4251c7b0, context=0x0, input=0x42519680, offset=0, count=384)
    at nsStreamListenerTee.cpp:56
#13 0x40b8b2b4 in nsHttpChannel::OnDataAvailable (this=0x4251c7b0,
    request=0x4251b100, ctxt=0x0, input=0x42519680, offset=0, count=384)
    at nsHttpChannel.cpp:2230
#14 0x40b4c2ae in nsOnDataAvailableEvent::HandleEvent (this=0x8681e80)
    at nsStreamListenerProxy.cpp:178
#15 0x40b3729d in nsARequestObserverEvent::HandlePLEvent (plev=0x8681e80)
    at nsRequestObserverProxy.cpp:64
#16 0x401d5a61 in PL_HandleEvent (self=0x8681e80) at plevent.c:590
#17 0x401d62bd in PL_ProcessEventsBeforeID (aSelf=0x80bb688, aID=7250)
    at plevent.c:1256
#18 0x40d80e9f in processQueue (aElement=0x80bb688, aData=0x1c52)
    at nsAppShell.cpp:464
#19 0x4018ef78 in nsVoidArray::EnumerateForwards (this=0x81357c0,
    aFunc=0x40d80e70 <processQueue(void *, void *)>, aData=0x1c52)
    at nsVoidArray.cpp:635
#20 0x40d80ef8 in nsAppShell::ProcessBeforeID (aID=7250) at nsAppShell.cpp:472
#21 0x40d8d217 in handle_gdk_event (event=0x8224820, data=0x0)
    at nsGtkEventHandler.cpp:990
#22 0x4045d6c4 in gdk_event_dispatch (source_data=0x0,
    current_time=0xbffff54c, user_data=0x0) at gdkevents.c:2129
#23 0x4048cc06 in g_main_dispatch (dispatch_time=0xbffff54c) at gmain.c:656
#24 0x4048d233 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#25 0x4048d3fc in g_main_run (loop=0x8186e80) at gmain.c:935
#26 0x403aa8cc in gtk_main () at gtkmain.c:476
#27 0x40d80ae5 in nsAppShell::Run (this=0x811a860) at nsAppShell.cpp:349
#28 0x409a3012 in nsAppShellService::Run (this=0x811ddc8)
    at nsAppShellService.cpp:427
#29 0x0805c7f7 in main1 (argc=2, argv=0xbffff8ec, nativeApp=0x0)
    at nsAppRunner.cpp:1346
#30 0x0805d661 in main (argc=2, argv=0xbffff8ec) at nsAppRunner.cpp:1668
#31 0x405d7baf in __libc_start_main () from /lib/libc.so.6                      

Updated

17 years ago
Keywords: crash

Comment 3

17 years ago
This looks like a dup of bug 96440.

*** This bug has been marked as a duplicate of 96440 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verified dupe
Status: RESOLVED → VERIFIED
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.