Closed Bug 966606 Opened 7 years ago Closed 7 years ago

[Australis] Buttons with long labels overlap in Customize mode

Categories

(Firefox :: Toolbars and Customization, defect)

x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- verified
firefox30 --- verified

People

(Reporter: flod, Assigned: jaws)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P3][fixed by bug 897496])

Attachments

(3 files)

Button with long labels are displayed correctly in Australis menu, but in Customize mode there's apparently less padding and elements overlap (see screenshot).

(not sure if it should depend on bug 872617).
Why isn't "nuova finestra annonima" hyphenized? Note that after bug 897496, it won't look OK anymore in the menu panel, even if it'll solve the overlap issue.
Whiteboard: [Australis:P3]
This label is made of 3 words that can be displayed individually on a single line, hence no hyphens.
But then I see "Schermo intero" hyphenated, so I have no real answer.
Fun fact: in Windows 8.1 those buttons wraps in both view and customize mode.
I suspect bug 897496 fixed this. Francesco, is that right?
Flags: needinfo?(francesco.lodolo)
Attached image screenshot.png
Yes, I see know a faded third line in both situations (standard menu, customization mode)
Flags: needinfo?(francesco.lodolo)
Even if I'm not sure why it wraps on Windows (just checked Windows 7 too, same behavior of Win8.1) but not on Mac.
(In reply to Francesco Lodolo [:flod] from comment #6)
> Even if I'm not sure why it wraps on Windows (just checked Windows 7 too,
> same behavior of Win8.1) but not on Mac.

Fairies! :-)

Seriously though, no idea. Do your windows machines have a non-default DPI setting? If so, it might be rounding errors. Otherwise, don't know. Separate bug, however, and not as serious as this one.
Blocks: 897496
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
(In reply to :Gijs Kruitbosch from comment #7)
> Seriously though, no idea. Do your windows machines have a non-default DPI
> setting? If so, it might be rounding errors. Otherwise, don't know. Separate
> bug, however, and not as serious as this one.

It could be a good explanation. I think I've changed the settings on both machines to have a bigger font, I'll check tomorrow on a third one with standard settings.
Assignee: nobody → jaws
Target Milestone: --- → Firefox 30
Whiteboard: [Australis:P3] → [Australis:P3][fixed by bug 897496]
QA Contact: cornel.ionce
Verified as fixed in latest Aurora 29.0a2 and latest Nightly 30.0a1 using Mac OS X 10.8.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.