Closed Bug 966709 Opened 9 years ago Closed 9 years ago

TEST-UNEXPECTED-FAIL | C:/slave/test/build/tests/xpcshell/tests/toolkit/components/telemetry/tests/unit/test_TelemetrySendOldPings.js | Found 2 unexpected saved pings.

Categories

(Toolkit :: Telemetry, defect)

29 Branch
x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 957123

People

(Reporter: rnewman, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=33963247&tree=Mozilla-Central

21:00:13     INFO -  TEST-INFO | C:\slave\test\build\tests\xpcshell\tests\toolkit\components\telemetry\tests\unit\test_TelemetrySendOldPings.js | running test ...
21:00:16  WARNING -  TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\xpcshell\tests\toolkit\components\telemetry\tests\unit\test_TelemetrySendOldPings.js | test failed (with xpcshell return code: 0), see following log:
21:00:16     INFO -  >>>>>>>
21:00:16     INFO -  \x0D
...
21:00:16  WARNING -  TEST-UNEXPECTED-FAIL | C:/slave/test/build/tests/xpcshell/tests/toolkit/components/telemetry/tests/unit/test_TelemetrySendOldPings.js | Found 2 unexpected saved pings. - See following stack:
21:00:16     INFO -  JS frame :: C:/slave/test/build/tests/xpcshell/tests/toolkit/components/telemetry/tests/unit/test_TelemetrySendOldPings.js :: assertNotSaved :: line 136
21:00:16     INFO -  JS frame :: C:/slave/test/build/tests/xpcshell/tests/toolkit/components/telemetry/tests/unit/test_TelemetrySendOldPings.js :: test_overdue_pings_trigger_send :: line 231
21:00:16     INFO -  JS frame :: resource://gre/modules/Task.jsm :: TaskImpl_run :: line 233
21:00:16     INFO -  JS frame :: resource://gre/modules/Promise.jsm :: Handler.prototype.process :: line 767
21:00:16     INFO -  JS frame :: resource://gre/modules/Promise.jsm :: this.PromiseWalker.walkerLoop :: line 531
21:00:16     INFO -  native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
21:00:16     INFO -  \x0D
21:00:16     INFO -  TEST-INFO | (xpcshell/head.js) | exiting test
21:00:16     INFO -  \x0D
21:00:16  WARNING -  TEST-UNEXPECTED-FAIL | resource://gre/modules/commonjs/sdk/core/promise.js | Unexpected exception 2147500036
I believe that this should fix the issue.
Attachment #8379672 - Flags: review?(rvitillo)
Comment on attachment 8379672 [details] [diff] [review]
Avoiding a race condition in the test

Review of attachment 8379672 [details] [diff] [review]:
-----------------------------------------------------------------

Your patch seems to be based on an older version of test_TelemetrySendOldPings.js; assertNotSaved has already been rewritten to use OS.File.
Attachment #8379672 - Flags: review?(rvitillo) → review-
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 957123
You need to log in before you can comment on or make changes to this bug.