Maximize, Restore, Close buttons disappear while tabstrip is animating and theme is in use

RESOLVED DUPLICATE of bug 940455

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 940455
4 years ago
4 years ago

People

(Reporter: DrBill, Unassigned)

Tracking

29 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140202030204

Steps to reproduce:

Nightly 29.0a1 (2014-02-02), with new, clean profile.
Build identifier: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Core 2 Q6600, 8GB RAM, GeForce GTX 260 Driver:332.21 WHQL.

Install any theme from AMO.
Open a second tab.
Reorder the position of the two tabs in the tabstrip by dragging one over the other with your mouse.


Actual results:

Observe the minimize/restore/close button group disappear while the tab switch is animating.  As soon as the animation finishes, the button group reappears and functions as expected.

If you're careful and keep the mouse button depressed and move the tabs over each other in a back-and-forth fashion, you'll note that moving the right tab over the left results in a ~1 second disappearance time as opposed to switching the left over the right tab, which is only a ~250ms disappearance time.


Expected results:

The minimize/restore/close button group should not have disappeared while the tabstrip is animating.
(Reporter)

Updated

4 years ago
Component: Untriaged → Theme

Comment 1

4 years ago
I'm 99% sure this is basically the same issue as bug 940455, so I'm duping and raising the priority there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940455
You need to log in before you can comment on or make changes to this bug.