2nd browser first sign in confusing

RESOLVED WORKSFORME

Status

()

Firefox
Sync
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: ozten, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

(Reporter)

Description

4 years ago
Steps to reproduce

1) Create a new Sync account on Nightly browser A
2) Sign in to account on Nightly browser B

Actual:
Everything looks fine, but if you go into Preferences to confirm... status of Sync is "needs login"

Log in a second time - Asked to verify email

If I hadn't poked around, I wouldn't have noticed that I wasn't actually using Sync on browser B.

Expected:
Use if directed through these steps during first run in either browser A or B. No double login required.
Blocks: 799726, 905997
Whiteboard: [qa+]
No longer blocks: 799726
Blocks: 969593
Component: Firefox Sync: UI → Sync
Product: Mozilla Services → Firefox
I have noticed that it can take a few moments for a signed in state to appear in Prefs panel immediately after sign-in.  Austin, is that what you're seeing? Or are you actually being forced to sign in again?
(Reporter)

Comment 2

4 years ago
I'm not sure. I do eventually get signed in.
http://dl.dropbox.com/u/10060532/Screenshots/151V.png

I haven't filed a separate bug, but I wasn't clear what should be getting synced.
I don't see my history or bookmarks flowing into these browsers, but they both look like that screenshot.

So, probably I'm just confused ;)
No longer blocks: 969593
There have been a lot of improvements to this flow since the bug was filed, I'm going to close it out.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.