Closed Bug 966847 Opened 6 years ago Closed 4 years ago

Microphone detaches prematurely from web audio

Categories

(Core :: WebRTC: Audio/Video, defect)

26 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 934512

People

(Reporter: clemens.cap, Unassigned)

Details

Attachments

(1 file)

Attached file testcase-fail.html
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

The most simple audio application fails with the enclosed test case. The test case can be fixed by a simple change in JavaScript, which should not have an impact on the behavior of the program.


Actual results:

0) Plug in headset and microphone (recommend not to use loud speakers to prevent audio feedback loop)
1) Load testcase-fail.html from server
2) Share the microphone
3) Listen as the sound produced in the microphone reproduce in the headset

After 5 - 15 seconds unexpectedly the microphone symbol vanishes, the mic detaches from the system and the headset no loner echoes the sounds in the microphone.

Now remove the "var" in front of "input" and run the same test. NOW the microphone does not detach and the application continues running.

I suspect that the object produced by the createMediaStreamSource has a memory management bug in the C++ implementation and thus, when it is presented to JavaScript in a "var" gets garbage collected too early, where as when it is stored in a global reference, it is not garbage collected).




Expected results:

In my opinion, having a var or not in place should not make a difference in the behavior of the program.
Component: Untriaged → General
OS: Linux → Windows 7
Hardware: x86_64 → x86
Component: General → WebRTC: Audio/Video
Product: Firefox → Core
Paul, do you think this is fixed?
Flags: needinfo?(padenot)
No, this still happens.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(padenot)
Resolution: --- → DUPLICATE
Duplicate of bug: 934512
You need to log in before you can comment on or make changes to this bug.