Closed Bug 966861 Opened 6 years ago Closed 6 years ago

Up/down arrow not displayed for <input type="number"> on Wndows7 Classic visual style

Categories

(Core :: Layout: Form Controls, defect, P4)

28 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
mozilla30
Tracking Status
firefox27 --- unaffected
firefox28 --- disabled
firefox29 + verified
firefox30 + verified

People

(Reporter: alice0775, Assigned: jwatt)

References

()

Details

(Keywords: regression, testcase)

Attachments

(2 files, 1 obsolete file)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/3e40f7389d1b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140202030204

Up/down arrow not displayed for <input type="number"> on Wndows7 Classic visual style.

On the other hand, It displayed on Windows7 Aero/Basic visual style.
Regression window with force dom.forms.number = true

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/1401e4b394ad
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131206030202
Bad:
http://hg.mozilla.org/mozilla-central/rev/a3a07fabaa58
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131206043331
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1401e4b394ad&tochange=a3a07fabaa58



Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/328d23950f63
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131205080810
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d6a365b059e3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131205082111
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=328d23950f63&tochange=d6a365b059e3

Suspected:
 Bug 935508 - Implement native theming of <input type=number>. r=roc
Attached image screenshot
This is reproducible on Windows XP classic too
Severity: major → normal
Keywords: testcase
Priority: -- → P4
Attached patch patch (obsolete) — Splinter Review
Turns out this is because reflow is giving the spin buttons' frames zero size, which is because nsNativeThemeWin::ClassicGetMinimumWidgetSize isn't handling these theme elements.
Assignee: nobody → jwatt
Attachment #8369764 - Flags: review?(roc)
Attached patch patchSplinter Review
Attachment #8369764 - Attachment is obsolete: true
Attachment #8369764 - Flags: review?(roc)
Attachment #8369766 - Flags: review?(roc)
Do we need a checkin-needed flag here or will you be landing this to inbound soon?  Would be great to get this confirmed on Nightly so we can uplift to Aurora/Beta and get more coverage before shipping.
Flags: needinfo?(jwatt)
https://hg.mozilla.org/mozilla-central/rev/311053a3b3ad
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Comment on attachment 8369766 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug in new feature (bug 344616)
User impact if declined: number controls broken on Win 7/XP with classic theme
Testing completed (on m-c, etc.): merged to m-c
Risk to taking this patch (and alternatives if risky): low risk, early in aurora
String or IDL/UUID changes made by this patch: none
Attachment #8369766 - Flags: approval-mozilla-aurora?
Attachment #8369766 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

Reproduced the initial issue with Windows Classic theme.
Verified as fixed on latest Aurora 29.0a2 (20140312004002) and latest Nightly (20140311030201).
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.