Buttons don't display highlighted state on touchstart

RESOLVED DUPLICATE of bug 819112

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 819112
5 years ago
3 years ago

People

(Reporter: jimm, Unassigned)

Tracking

(Depends on 1 bug)

Trunk
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=0)

Reporter

Description

5 years ago
I'm pretty sure this is a missing feature in platform, although we could probably fix it in front end as well. When you tap down on a chrome button (say in an alert box), the button should highlight but doesn't. So button presses provide no user feedback.

Comment 1

5 years ago
The theme code handles both hover and active states. For the touchstart case, do either of these get set and which ones should be?
Blocks: metrobacklog
Whiteboard: [defect] p=0
Reporter

Comment 2

5 years ago
(In reply to Neil Deakin from comment #1)
> The theme code handles both hover and active states. For the touchstart
> case, do either of these get set and which ones should be?

I'm pretty sure it should be active, just like a mouse down. Currently this doesn't get set for touchstart AFAICT, there's no change in the button when you press down on it. Comparing that to mouse down behavior shows there is an active state defined. (I'm testing on alert()).
The underlying core bug is bug 819112.
Depends on: 819112
Reporter

Updated

5 years ago
No longer blocks: 934504
Whiteboard: [defect] p=0 → p=0
Reporter

Comment 5

5 years ago
(In reply to Matt Brubeck (:mbrubeck) from comment #4)
> The underlying core bug is bug 819112.

Would it be ok to fix this in front end similar to other platforms, or would that be considered a total cop out on the platform work (which sound kinda yucky). :)
Depends on: 976605
This might be subtly different from bug 819112 but it's close enough that I'm comfortable duping it given that Metro is no longer a thing.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819112
You need to log in before you can comment on or make changes to this bug.