Firefox Accounts (Sign In) - Weird spinning animation in the Sign in button (Gingerbread)

VERIFIED FIXED

Status

()

Firefox for Android
Android Sync
VERIFIED FIXED
4 years ago
2 months ago

People

(Reporter: Flaviu Cos, Assigned: nalexander)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox29 verified, firefox30 verified, firefox31 verified)

Details

(Whiteboard: [2.3 only])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8369480 [details]
The file  is a screen capture

Environment: 
Device: Motorola Atrix (Android 2.3.4);
Build: Nightly 29.0a1 (2014-02-03).

Steps to reproduce:
1. Go to Settings ->  -> Add account -> Firefox;
2. Tap on 'Already have an account? Sign in' message;
3. Fill the email and password with valid credentials;
4. Tap on Sign in button.

Expected result:
The animation from the Sign in button is correctly displayed.

Actual result:
There is a weird animation in the Sign in button.

Note:
Not reproducible on tablets or devices with android 4.x.
Please check the attached screen capture.
(Reporter)

Updated

4 years ago
status-firefox29: --- → affected
Hmm, I saw this once on an older device myself, and it was so strange I shrugged it off.  I'm pretty sure it's a bug with Android's progress bar on older devices, but thanks for confirming.  Will see what we can do.
Yeah just ran into this on my 2.3 Motorola Droid Bionic. It's a wild trip when it animates.

Updated

4 years ago
status-firefox30: --- → affected
Whiteboard: [2.3 only?]
Correct. Still see this.
Summary: Firefox Accounts (Sign In) - Weird spinning animation in the Sign in button → Firefox Accounts (Sign In) - Weird spinning animation in the Sign in button (Gingerbread)
Whiteboard: [2.3 only?] → [2.3 only]
Okay, this appears to be a Gingerbread and Froyo issue; at least a few other people have seen it:

http://grokbase.com/t/gg/android-developers/12b8h0zs7d/progressbar-proportions-problem

To size the progress bar to the button it replaces, I had both in a containing RelativeLayout and set the progress bar layout edges to match the container's edges.  That doesn't work because this bug busts the animation when you stretch the progress bar.  Instead, I've set the background of the containing RelativeLayout to match the button and centered the (un-stretched) progress bar in it.

Tested locally on my Samsung Galaxy Tab (Android 3.0?, which previously displayed the bad animation) and my Samsung Galaxy SII (Android 4.1?, which did not).
Created attachment 8390712 [details] [review]
github PR
Assignee: nobody → nalexander
Status: NEW → ASSIGNED
Attachment #8390712 - Flags: review?(rnewman)
Comment on attachment 8390712 [details] [review]
github PR

rubberstamp: if this works, I see nothing wrong with it.
Attachment #8390712 - Flags: review?(rnewman) → review+
https://hg.mozilla.org/integration/fx-team/rev/1d147df673e3
https://hg.mozilla.org/mozilla-central/rev/1d147df673e3
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

4 years ago
Verified as fixed in builds:
- 31.0a1 (2014-04-07);
- 30.0a2 (2014-04-07);
Device: Motorola Atrix (Android 2.3.4);

The bug is still reproducible on Firefox Beta 4.
status-firefox30: affected → verified
status-firefox31: --- → verified
Thanks, :flaviu.  This is an easy uplift; requesting.
Created attachment 8402706 [details] [diff] [review]
1d147df673e3

[Approval Request Comment]
Bug caused by (feature/regressing bug #): initial FxA landing.

User impact if declined: horrible animation shows.  Only on Android 2.3 devices, which make up 19% of the Android eco-system, IIRC.

Testing completed (on m-c, etc.): tested and QA verified on 31 and 30.

Risk to taking this patch (and alternatives if risky): very low.  Visual change only.

String or IDL/UUID changes made by this patch: none.
Attachment #8402706 - Flags: approval-mozilla-beta?
Attachment #8402706 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/26f9d2df24af
status-firefox29: affected → fixed
(Reporter)

Comment 13

4 years ago
The bug is still reproducible on Firefox 29 beta 6;
Device: Motorola Atrix (Android 2.3.4);
I downloaded 29b6 from

http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/29.0b6-candidates/build1/android/en-US/fennec-29.0b6.en-US.android-arm.apk

It's built from https://hg.mozilla.org/releases/mozilla-beta/rev/274a8f367ac7.

I can confirm :flaviu's comment that this is not fixed.  Digging in to understand why.

Updated

4 years ago
status-firefox29: fixed → affected
This is simple but terrifying: the b6 build does not include the relevant change, for reasons I don't understand.  The immediately previous build, from

https://tbpl.mozilla.org/?tree=Mozilla-Beta&rev=26f9d2df24af

with direct link

http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-beta-android/1396896304/fennec-29.0.en-US.android-arm.apk

has the fix and works fine.  So this looks to be something funky with the buildbots, or the build system.  Digging in.
(In reply to Nick Alexander :nalexander from comment #15)
> This is simple but terrifying: the b6 build does not include the relevant
> change, for reasons I don't understand.

RyanVM helped me see that the relevant commit just missed beta; you can see this at https://hg.mozilla.org/releases/mozilla-beta/graph/183652

:flaviu: so this will have to wait until b7 :(  So close.  In any case, I'm confident it's fixed; you could verify with your device against the build I linked to above.
status-firefox29: affected → fixed
(Reporter)

Comment 17

4 years ago
The bug is not reproducible on the thinderbox-build from comment 15.
Will close the bug after retesting on the next beta build.
(Reporter)

Comment 18

4 years ago
Verified as fixed in build 29;
Device: Motorola Atrix (Android 2.3.4).
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified

Updated

2 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.