Closed Bug 967032 Opened 7 years ago Closed 7 years ago

Intermittent testAdobeFlash | "Process crashed?" on tegra

Categories

(Firefox for Android Graveyard :: Testing, defect)

x86
macOS
defect
Not set
normal

Tracking

(firefox28 unaffected, firefox29 fixed, firefox30 fixed, firefox-esr24 unaffected)

RESOLVED FIXED
Firefox 30
Tracking Status
firefox28 --- unaffected
firefox29 --- fixed
firefox30 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: gbrown, Assigned: esawin)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Bug 722166 has various crashes and possible crashes in it. Some of the recent reports are for testAdobeFlash on tegra:

https://tbpl.mozilla.org/php/getParsedLog.php?id=33943766&full=1&branch=mozilla-inbound#error0

https://tbpl.mozilla.org/php/getParsedLog.php?id=33912035&full=1&branch=mozilla-inbound#error0

Robocop jobs that end very fast sometimes show this behavior. I think the issue is that the crashreporter has not been initialized before the test ends.

Suggestions for resolving this:
 - skip the test entirely on tegra (Android SDK 8) via robocop.ini
 - blockForGeckoReady in the test, at least on Tegra
Blocks: 722166
We don't run the Flash tests on 2.2, so I think the presence of testAdobeFlash is a red herring. It looks like it failed to acquire a surface on startup.
Assignee: snorp → esawin
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #1)
> We don't run the Flash tests on 2.2, so I think the presence of
> testAdobeFlash is a red herring. It looks like it failed to acquire a
> surface on startup.

The Flash tests don't run, but testAdobeFlash is executed:

02-01 06:06:40.982 I/Robocop ( 2695): 0 INFO SimpleTest START
02-01 06:06:40.982 I/Robocop ( 2695): 1 INFO TEST-START | testAdobeFlash

I am pretty sure that the issue is that the test ends before gecko (and especially the crashreporter) is initialized -- see simple solutions in Comment 0.
(In reply to Geoff Brown [:gbrown] from comment #2)
> (In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #1)
> > We don't run the Flash tests on 2.2, so I think the presence of
> > testAdobeFlash is a red herring. It looks like it failed to acquire a
> > surface on startup.
> 
> The Flash tests don't run, but testAdobeFlash is executed:
> 
> 02-01 06:06:40.982 I/Robocop ( 2695): 0 INFO SimpleTest START
> 02-01 06:06:40.982 I/Robocop ( 2695): 1 INFO TEST-START | testAdobeFlash
> 
> I am pretty sure that the issue is that the test ends before gecko (and
> especially the crashreporter) is initialized -- see simple solutions in
> Comment 0.

Indeed, I see that now. Eugen please try calling blockForGeckoReady() and see if that fixes things.
Adding blockForGeckoReady() for pre 4.0 Android versions fixes the failed test locally and so far looks good on Try (https://tbpl.mozilla.org/?tree=Try&rev=36dca65b31cb), but the crash is not that frequently occurring there ( https://tbpl.mozilla.org/?tree=Try&rev=f882da366aea).
Attachment #8370797 - Flags: review?(snorp)
Attachment #8370797 - Flags: review?(snorp) → review+
https://hg.mozilla.org/mozilla-central/rev/8a2d8a022387
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.