When opening a local page in Composer, the preview pane displays html.

NEW
Unassigned

Status

18 years ago
9 years ago

People

(Reporter: TucsonTester1, Unassigned)

Tracking

({helpwanted})

Trunk
Future
PowerPC
All
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
1. Launch Netscape.
2. Click the Composer icon at the bottom of the Navigator window to open 
a blank page to edit.
3. Type some text.  
4.Click the Save icon at the top of the Composer window.
5. In the Page Title box that opens, type "Preview Test".
6. In the Save Page As box, choose Desktop from the Location menu at 
the top, and hit Enter or Return.  The page will be saved to the desktop.
7. In Composer, click the Open button at the top of the screen.
8. In the Open HTML File box, choose Desktop from the Location menu at 
the top.
9. Locate the file named Preview_Test.html.
10. Click on Preview_Test.html one time only to highlight it.
11.  Locate the Show Preview button in the lower right corner of the Open 
HTML File box, and click on it one time only.

Result:
The preview pane displaysthe page in HTML format instead of displaying 
an approximation of what the page looks like.

Date: 
8/23/01

Comment 1

18 years ago
Reporter, what Build ID are you using?

Comment 2

18 years ago
hmm... I get  a "no preview available' message for the html file on my desktop. 
(Reporter)

Comment 3

18 years ago
This only occurs in OS 8.6, and not OS 9.0.4, or 9.1.  I have not tested it in 
other Mac OS's.

Build 20010821 Netscape6/6.1b1

Updated

18 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 4

18 years ago
Reporter, you must report bugs with Netscape's builds on their bug reporting form 
([http://help.netscape.com/forms/bug-client.html]). Marking this bug INVALID for now.

If you wish, download a 0.9.3 build and retest with that. If you can reproduce using a 
Mozilla.org version, then don't hesitate to reopen this.

Comment 5

18 years ago
marking verified. REOPEN if you see this still happening in current build.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

18 years ago
QA build 20010911 Netscape6/6.2

This is still occurring in the above build.

Note:  Only occurs in Mac OS 8.6.
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

18 years ago
Reporter, that is still a Netscape build. You MUST download a Mozilla build from 
Mozilla.org to report bugs to Bugzilla.

Do NOT report any additional bugs pertaining to a Netscape QA build to Bugzilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID

Comment 8

18 years ago
Greg:

Bugs found in Netscape QA Builds are still valid issues, and will be reported 
through Bugzilla.  Please don't close bugs against QA builds as invalid.

~James Baxter
 Software QA Engineer
 America Online

Comment 9

18 years ago
Reopening bug for clarification.

I am using a Mac Mozilla Debug build from yesterday.
When I try to preview any of my html or text files, I see "No preview available." 
in that area.

Reporter--is this what you are talking about?

Newly cc'd people--opinions??
Status: RESOLVED → UNCONFIRMED
Keywords: pp
Resolution: INVALID → ---

Comment 10

18 years ago
James Baxter--could you clarify on what you expect to happen for this bug?

Setting milestone to Future until we can truly assess.
Target Milestone: --- → Future

Comment 11

18 years ago
Brade - I was simply asking that this bug *not* be marked invalid because it 
was reported on a QA build.  I am not sure as far as the behavior goes - it 
looks like the reporter is seeing HTML tags in the Preview screen, and they 
expect the page to appear as it would in a web browser.

Comment 12

18 years ago
To fix this, we'd have to do a Nav services preview proc that embeds Gecko in the 
Nav services dialog. Scarey.
Status: UNCONFIRMED → NEW
Ever confirmed: true
does IE do a preview in their html open file dialog?

Comment 14

18 years ago
This isn't specific to Composer.  Presumably Navigator also has this problem with 
the Standard Open dialog.  I wouldn't be surprised if a duplicate bug of this 
existed.

-->XPApps GUI Features for reassignment/evaluation
Assignee: brade → blakeross
Component: Editor: Core → XP Apps: GUI Features
QA Contact: sujay → sairuh
Target Milestone: Future → ---

Comment 15

18 years ago
IE does not preview HTML docs.  If the file has a .html extension you just get a 
document icon as the preview.  If it's .txt you'll see the first few lines of the 
file.  Not that this wouldn't be an interesting enhancment (hrm, embed Gecko in a 
NavServices dialog, maybe scary is a better term :-) but it certainly isn't what 
I'd consider a problem/bug.

Comment 16

18 years ago
Oops, forgot to say that I'm using Mac OS X and referring to the version of IE 
with Mac OS X when I say it doesn't do previews

Updated

17 years ago
Target Milestone: --- → Future
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 18

16 years ago
This bug applies to all MacOS.
Keywords: pp → helpwanted
OS: Mac System 8.6 → All
Product: Core → Mozilla Application Suite
Assignee: bross2 → guifeatures
QA Contact: bugzilla
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: guifeatures

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.