Closed Bug 967149 Opened 8 years ago Closed 8 years ago

Change UA for GMail to properly display fonts on QHD display screen

Categories

(Web Compatibility :: Mobile, defect, P1)

x86
macOS

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 668275

People

(Reporter: faramarz, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-all] [css] [notcontactready])

Attachments

(1 file)

GMail on a Peak (using the browser) is unreadable because it's too small.  The UA needs to be fixed for proper display.
Component: Gaia::Browser → Mobile
Product: Firefox OS → Tech Evangelism
faramarz,

could we have a better description of the bug, the URL you have accessed?
Which difference you noticed with other browsers?
What do you mean by the UA needs to be fixed? Which UA did you use?

Without a more complete information, I'm likely to close it as INVALID :) With a more detailed description I can figure out, if it's a duplicate.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Flags: needinfo?(frashed)
Whiteboard: [country-all]
STR:

1. Grab any FxOS phone (Peak, Keon...)
2. Open the browser.
3. Go to Gmail.

## Expected:
being able to read the screen and take action

## Actual:
screen is not rendered properly.  impossible to read/write/take-action
Flags: needinfo?(frashed)
Let's see.
1. With the open ZTE device with Firefox OS 1.2 in English. Starting Firefox
2. entering mail.google.com.
3. We are redirected to accounts.google.com
4. Entering the account information
5. Being redirected to the inbox https://mail.google.com/
6. Getting the main page with the inbox.

All icons are here, the list of messages are here.
The main screen shows for me around 6 messages.
Everything is rendered properly and is working.

Faramarz,

Do you mean that the UI and buttons are small?
Is it different on other browsers with the same screen size? 
It would help to have a screenshot of the experience you expect on a equivalent device. 
If you could provide it that would be cool.
If not different, it is a poor usability choice from Google but we can tell them, but without guarantee it will be fixed. ;) we can try.
Flags: needinfo?(frashed)
Adding gmail-ui-screenshot-zte.jpg showing the current UI of Gmail on a ZTE device.
Whiteboard: [country-all] → [country-all] [css]
See Also: → 668275
Your screenshot looks a lot better than what I see on my Peak device. My target touch-points are too small to the point that they're not useful. Loading up Yahoo mail on the same device has a much better experience. It's sized correctly. If you have a Peak-like device, please test on that and see if you can use Gmail on that.
Flags: needinfo?(frashed)
Faramarz, 
I do not have a peak. What is the system version of your Peak device?
could you upload a screenshot too?
To take a screenshot push at the same time the home and power buttons. 
It will save the image in the gallery. 
Thanks.
Whiteboard: [country-all] [css] → [country-all] [css] [notcontactready]
Fararmarz, 

The mistery is becoming deeper. :)
We have an opened bug for Yahoo! Mail. Bug 944507 Firefox OS is NOT receiving the mobile version. We receive a desktop version. I just put a screenshot so you can see what Yahoo! Mail is currently on Firefox OS. https://bug944507.bugzilla.mozilla.org/attachment.cgi?id=8388915

Could you tell me what is the version of your device  and upload a screenshot? :)
Settings -> Device Information
Model: 
Then ->  More Information
OS Version:
Hardware revision: 
Platform version: 


Thanks.
Let's move the bug to DUPLICATE of Bug 668275
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668275
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.