Closed Bug 967405 Opened 7 years ago Closed 3 years ago

[Gaia][Systems] Apps should be able to specify whether they show up in the Stack Manager / Cards View

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P2)

x86
macOS
defect

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: aus, Unassigned)

References

Details

(Whiteboard: [systemsfe][p=8] interaction-design)

Right now the System App ends up in the cards view when it shouldn't. Instead of special casing the system app in the stack manager we would rather provide a way for applications to specify if they show up in the cards view or not. This should be useful for applications that mostly do background work and potentially others such as replacement homescreen apps.
Whiteboard: [systemsfe]
Whiteboard: [systemsfe] → [systemsfe][p=8]
Target Milestone: 1.4 S1 (14feb) → ---
The wappush app is one of the apps that might benefit from this. It's currently setting the system role as it wants its icon hidden from the homescreen but starting with bug 966405 it wants to show up in the cards view under certain conditions. Note that we had also opened bug 943250 for this; the idea there was that applications that had not been launched via |app.launch()| would not be visible in the cards view. This way applications launched by a system message handler or something akin to that would effectively be hidden from the user unless the user himself would trigger them to call app.launch() somehow (by clicking on a notification for example).
Blocks: 966405
See Also: → 943250
Blocks: 960335
Whiteboard: [systemsfe][p=8] → [systemsfe][p=8] interaction-design
Gregor, Can we get this bug fixed in 2.1? 

See bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1030954

Thanks
Hema
Flags: needinfo?(anygregor)
feature-b2g: --- → 2.1
Flags: needinfo?(anygregor)
Hi,everyone.Is there any advance?
(In reply to liangxin from comment #3)
> Hi,everyone.Is there any advance?

This was just confirmed and scheduled for the 2.1 release. It's slated to get attention in the next sprint.
Target Milestone: --- → 2.0 S6 (18july)
Target Milestone: 2.0 S6 (18july) → 2.1 S1 (1aug)
Target Milestone: 2.1 S1 (1aug) → 2.1 S2 (15aug)
Hi,everyone.Is there any advance?
Hi,everyone.Is there any advance?
Target Milestone: 2.1 S2 (15aug) → 2.1 S3 (29aug)
(In reply to liangxin from comment #6)
> Hi,everyone.Is there any advance?

Liangxin, is there a certain use case that you want to use this capability for?
Flags: needinfo?(liang.xin)
(In reply to Peter Dolanjski [:pdol] from comment #7)
> (In reply to liangxin from comment #6)
> > Hi,everyone.Is there any advance?
> 
> Liangxin, is there a certain use case that you want to use this capability
> for?

Please refer to comment 1. The wappush app is one of the apps that might benefit from this. For example bug 1013019 associated.
Flags: needinfo?(liang.xin)
Confirming what Lingxin said. To work around the lack of this functionality we had to deploy a very hacky and quite complicated workaround in the WAP Push app that automatically closes it when it's not needed. This has a lot of downsides and I'll be glad the day I can get rid of it.

Generally speaking there's other scenarios where this could be useful. For example we discussed making the SMS app not visible in the cards view if it's being opened by receiving a message and make it visible only when it's explicitly invoked by the user (either opened via the homescreen or via a notification).
OK. I think what I'm working on for this user story here -- bug 1058722, will go a long way towards making the desired behavior for WAP Push and SMS possible. We're adding the ability for the invoker of the task manager to set filters for the apps it will present. 

The current thinking is that one would set a filter function which would get called once when the task manager is constructing the cards. This method would receive the application instance object and return true for it to be included and false for it to be omitted. After the task manager is dismissed this filter function would need to be sent again for the same filtering to occur.
I'm removing the feature-b2g:2.1 flag since it's not clear that this will be done for FL and it is not committed.  Aus will certainly continue to work on the components that he mentioned in Comment 10, however.
blocking-b2g: --- → backlog
feature-b2g: 2.1 → ---
Aus, are you working on this or should we move it out of the sprint milestones?
Target Milestone: 2.1 S3 (29aug) → 2.1 S4 (12sep)
Priority: -- → P2
Target Milestone: 2.1 S4 (12sep) → ---
blocking-b2g: backlog → ---
Assignee: aus → nobody
Status: ASSIGNED → NEW
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.