:active not shown on mousedown for <a> containing inline

VERIFIED DUPLICATE of bug 65917

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 65917
17 years ago
17 years ago

People

(Reporter: John Morrison, Assigned: karnaze (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The :active state is not shown when doing mousdown on an anchor which contains
a child inline element (instead of a simple text node).

2001082308 win2k

<html>
<body>

<p>
In the anchor links below, if an &lt;a>&lt;/a> contains an inline element,
then the CSS :active link coloring is not shown on mousedown. 
</p>

<p>
Mousedown on each of the links below. The color should turn to red, but 
only the third example, with a simple text node contained in the anchor
element will do so.
</p>

  <a href="link-one"><b>Some Link</b></a>  
<br><br>
  <a href="link-two"><span>Some Link</span></a>
<br><br>
  <a href="link-tri">Some Link</a>

</body>
</html>
(Reporter)

Comment 1

17 years ago
Created attachment 46951 [details]
test case; anchor containing either inlines or simple text nodes
(Reporter)

Comment 2

17 years ago
Funny I should notice this now. This has been this way for quite some time.
In fact, I'm wondering if I've dredged up a long-standing bug (or if this 
is invalid for some reason [i.e., :active doesn't apply to descendants]).
Ian?
OS: Windows 2000 → All
Hardware: PC → All

Comment 3

17 years ago
I think this is a duplicate of bug 65917.

Comment 4

17 years ago
It could also be a duplicate of mostfreq bug 5693.
(Reporter)

Comment 5

17 years ago
I'll go with bug 65917. Thanks.

*** This bug has been marked as a duplicate of 65917 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

17 years ago
vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.