Closed Bug 96770 Opened 23 years ago Closed 23 years ago

Put palette API back into GFX

Categories

(Core :: Graphics: ImageLib, defect)

defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 95106

People

(Reporter: mkaply, Assigned: pavlov)

Details

Attachments

(2 files)

When libimg was removed, the API GetPaletteInfo was removed from gfx.

This API is essential for getting palette info between widget and gfx.

Once this is added back, we can put back in proper 256 color (palette 
management) support for Windows and Os/2.

Diff attached.
Blocks: 95106
What is keeping this bug from progressing? Wouldn't this help the situation with
low-color displays? Boy, this is ugly in a 256 color terminal...
I'll attach an image just so that you can see how ugly :)
how about low color embedded displays like a PDA device?  I think it would be
useful wouldn't it?
somebody probably needs to take time to add that back the build makers.. etc.. 
pavlov: please accept or reject this patch
just adding the API back isn't going to solve problems (yet).

I'm working on some new image drawing code for windows and unix, and the windows
code could take use of some of the palette code.  also, i would expect to see
GIFs being stored as 8bit paletted images sooner than later.

So until what I said above is completed, having the palette apis arn't going to
help anything.  Unless mkaply needs it back to fix OS2 bustage, i don't see any
reason in rushing the patch back in.
Pavlov,

What you removed was palette management. That is the important stuff for 256 
color.

It doesn't matter if you have 256 color image handling in imagelib if you don't 
have the palette management in.

This API is to pass the palette between widget and gfx; the rest is easy - 
create 256 color palette, realize that palette when you get the appropriate 
message on Windows or Os/2.

As far as the palette itself goes, my plan was just to hardcode a 256 color 
palette into each platforms GFX, unless you want to bring back the color cube.

If what you are talking about is creating a way for imagelib to render images 
down to 256 color or 16 color, that's great. We still need this API.
I've attached the entire fix for 256 color in 95106

*** This bug has been marked as a duplicate of 95106 ***
No longer blocks: 95106
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.