vid.ly (Air Mozilla) serves mp4 video, instead of webm, to Firefox 30 (Nightly)

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
5 years ago
3 years ago

People

(Reporter: Josh Aas, Unassigned)

Tracking

Trunk
x86_64
Mac OS X

Details

(URL)

WFM on Windows 8.1 in today's nightly. Weird, as that video is a WebM, so the decoding code paths should be the same on both OS's.
(Reporter)

Comment 2

5 years ago
Should have noted that I was testing on OS X 10.9 (MacBook Air).
(Reporter)

Comment 3

5 years ago
I think Gavin said he was able to repro this morning, not sure which OS he was on.
I'm also on OS 10.9.
This is a vid.ly UA detection problem. Air Mozilla serves webm video from vid.ly to Aurora, Beta, and Release, but it tries to serve mp4 video to Nightly. If I change Nightly's UA string to mimic Firefox 25, then Air Mozilla serves webm as expected.

Nightly has see the same problem on Vid.ly's home page: http://m.vid.ly/

HTTP "Content-Type" of "video/mp4" is not supported. Load of media resource https://vid.ly/3q8j1d?content=video&format=mp4 failed.
Summary: Air Mozilla video works in Firefox 27 release but not nightly → Air Mozilla (vid.ly) video works in Firefox 27 release but not Nightly
Vid.ly assumes that any UA with a version number beginning with the digit 3 can play mp4 video:

• Firefox/3.0   -> mp4
• Firefox/29.0  -> webm
• Firefox/30.0  -> mp4
• Firefox/39.0  -> mp4
• Firefox/40.0  -> webm
• Firefox/300.0 -> mp4
Assignee: nobody → english-us
Component: Video/Audio → English US
Product: Core → Tech Evangelism
Summary: Air Mozilla (vid.ly) video works in Firefox 27 release but not Nightly → vid.ly (Air Mozilla) serves mp4 video, instead of webm, to Firefox 30 (Nightly)
Duplicate of this bug: 969292
See http://s.vid.ly/vid.ly/8bcbb16-stable/js/html5.js?link=5u4h3e&new=1&autoplay=false&width=311&height=175:

In setPlayer:

if(ua.indexOf('Firefox/3') !=-1){
  type = "mp4";
  format = "mp4";
}

(thx to @vladikoff for pointing that out to me)

Comment 9

5 years ago
Cringe. I guess the right feature test should be

videoElement.canPlayType('video/mp4')

At least that return "" on mac nightly, which means it can't play this.

I hope we return "maybe" or "probably" on windows, and linux with codecs installed or so.

Comment 10

5 years ago
(In reply to Mike Taylor [:miketaylr] from comment #8)
> if(ua.indexOf('Firefox/3') !=-1){

Ouch.

FAIL.
(In reply to Axel Hecht from comment #9)
> Cringe. I guess the right feature test should be
> 
> videoElement.canPlayType('video/mp4')
 
Yes.

> At least that return "" on mac nightly, which means it can't play this.

Yes. We haven't shipped MP4/H.264/AAC support on MacOSX yet.

> I hope we return "maybe" or "probably" on windows, and linux with codecs
> installed or so.

We do.
I can file a ticket with Vid.ly's engineering team.  What's the proper way to decide what to serve Firefox, Firefox for Android, and Firefox on FirefoxOS?

If we're going to pester them to change it, then it would be good if they got it right the first time.

Comment 13

5 years ago
I *think* we always prefer open formats, but also, AFAIK, the <video> tag has a way to specify multiple sources with fallbacks so I guess that would be preferred. Otherwise, I think actual feature detection instead of UA detection is preferred in JS, though I don't know the code for codec detection.
That said, I wonder where that "Firefox/3" detection comes from, I think we didn't even ship <video> support with Firefox 3.x, did we?
Duplicate of this bug: 972875
Have an open ticket (#11942) with Vid.ly support that references this bug.
Vid.ly support escalating this issue to engineering.
Vid.ly reports that they have pushed a fix.  Firefox 30 should now be getting WebM.

Comment 18

4 years ago
Already test with some of newer videos and it work as expected.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Verified fixed with Nightly 31.
Status: RESOLVED → VERIFIED
status-firefox29: --- → unaffected
status-firefox30: --- → verified
status-firefox31: --- → verified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.