Closed Bug 967763 Opened 6 years ago Closed 5 years ago

crash in mozilla::gfx::Matrix::HasNonIntegerTranslation() const

Categories

(Core :: Graphics, defect, critical)

All
Linux
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox27 --- unaffected
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected

People

(Reporter: cork, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-f36a4278-344d-4a4a-9ecb-620d82140204.
=============================================================

STR:
 1. Create a new profile
 2. Open about:config and change gfx.content.azure.backends to "skia"

Tested on Archlinux with NVidia binary drivers
Blocks: 740200
Nightly30.0a1 bp-6324d63c-ddf3-4b32-be52-322bc2140205
Aurora28.0a2  bp-1a8efd6c-0f56-4567-af3d-a545c2140205


Regression window(m-c nightly)
Good:
http://hg.mozilla.org/mozilla-central/rev/99479edbee2a
Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131126052050
Crash:
http://hg.mozilla.org/mozilla-central/rev/6ecf0c4dfcbe
Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131127030201
27-Nov-2013 1229 nightly
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=99479edbee2a&tochange=6ecf0c4dfcbe



Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c9ff42335f8a
Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131126162552
Crash:
http://hg.mozilla.org/integration/mozilla-inbound/rev/35014d18ff1f
Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131126163055
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c9ff42335f8a&tochange=35014d18ff1f


Triggered by: Bug 932888
Blocks: 932888
Crash Signature: [@ mozilla::gfx::Matrix::HasNonIntegerTranslation() const] → [@ mozilla::gfx::Matrix::HasNonIntegerTranslation() const] [@ ClipToRegionInternal]
Keywords: regression
Seems to be fixed on Firefox 33 (Nightly).
Gets a bit strange fix rangs, but i suspect this might have been fixed by bug 994924
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.