The titlebar is too short when using an lw-theme on OS X with tabs in titlebar disabled

RESOLVED FIXED in Firefox 29

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mconley, Assigned: adw)

Tracking

(Blocks 1 bug)

Trunk
Firefox 30
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 fixed, firefox30 fixed)

Details

(Whiteboard: [Australis:P3][good first verify])

Attachments

(5 attachments, 3 obsolete attachments)

STR:

1) Apply a lightweight theme
2) Enter customize mode, and re-enable the titlebar

ER:

The titlebar should be the same height as it is without a lightweight theme.

AR:

The titlebar is slightly shorter. This effect is amplified when opening a pop-up window (with or without tabs in titlebar disabled).
Posted file testcase.html
Quick and dirty method of testing popup windows, cribbed from bug 930094.
Assignee

Comment 3

5 years ago
Posted patch blind fixSplinter Review
Well, this fixes it, but I can't tell you why it happens. :-/
Attachment #8373815 - Flags: review?(mconley)
Comment on attachment 8373815 [details] [diff] [review]
blind fix

Review of attachment 8373815 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks adw!

::: browser/themes/osx/browser.css
@@ +4127,5 @@
>    margin-bottom: 0px;
>  }
>  
> +#main-window:not([tabsintitlebar]):-moz-lwtheme > #titlebar {
> +  margin-bottom: 5px;

This growing set of hard-coded titlebar values is a little disturbing, but I guess I made the bed - I might as well lie in it. :)

I think this works. I ran it through tests with customize mode, tabs in titlebar on and off, with and without lightweight themes, and opening popups. Works as advertised.

Down the road, I'd really like to make our titlebar stuff smarter, but for now, let's go with this.
Attachment #8373815 - Flags: review?(mconley) → review+
We'll also want to land this on Aurora once it's had some time to bake on central.
Assignee

Comment 6

5 years ago
https://hg.mozilla.org/integration/fx-team/rev/333e64e85ffb
Assignee: nobody → adw
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/333e64e85ffb
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8373815 [details] [diff] [review]
blind fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

Bug 930094, Australis.


User impact if declined: 

Users with lw-themes will find their titlebars just a little too short on OS X.


Testing completed (on m-c, etc.): 

A few days of testing on m-c hasn't turned up anything wrong with this.


Risk to taking this patch (and alternatives if risky): 

Very low - CSS only.


String or IDL/UUID changes made by this patch:

None.
Attachment #8373815 - Flags: approval-mozilla-aurora?
Attachment #8373815 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
Whiteboard: [Australis:P3] → [Australis:P3][good first verify]
[bugday-20140409]
x86 Mac OSX 10.9.2
Aurora 30.0a2 (2014-04-09)

I'm not clear what is the difference between a lightweight theme and non-lightweight theme but am posting verification results.

In Aurora, I applied the theme, Dragonflies in Maple Tree (by MaDonna).
The tabs don't appear to be too close to the window controls in the main window.
But when I test on Mike Conley's test popup (https://bug967836.bugzilla.mozilla.org/attachment.cgi?id=8370335) with no tabs, the address bar is close to the window controls (the title bar seems a little smaller).

I'm not clear whether the fix is good enough to say it is verified.
Posted image aurora_theme_with_tabs.png (obsolete) —
Ex. screenshot of Aurora with theme applied with tabs.
Posted image aurora_theme_popup_no_tabs.png (obsolete) —
Ex. screenshot of Aurora with theme applied, in a popup without tabs
This screenshot, if compared to attachment 8404144 [details], does appear to have a shorter titlebar. I saw a similar result when I tried with 2 other popular themes.
Oh, I googled lightweight theme and found some information. I will look into it and then try to retest this.

https://developer.mozilla.org/en-US/Add-ons/Themes/Lightweight_themes

(In reply to lizardwalk5 from comment #10)
> [bugday-20140409]
> x86 Mac OSX 10.9.2
> Aurora 30.0a2 (2014-04-09)
> 
> I'm not clear what is the difference between a lightweight theme and
> non-lightweight theme but am posting verification results.
> 
> In Aurora, I applied the theme, Dragonflies in Maple Tree (by MaDonna).
> The tabs don't appear to be too close to the window controls in the main
> window.
> But when I test on Mike Conley's test popup
> (https://bug967836.bugzilla.mozilla.org/attachment.cgi?id=8370335) with no
> tabs, the address bar is close to the window controls (the title bar seems a
> little smaller).
> 
> I'm not clear whether the fix is good enough to say it is verified.
Posted image screen_aurora_ltw_theme_tabs.png (obsolete) —
Updated screenshot of Aurora with lightweight theme applied. With tabs.
Attachment #8404144 - Attachment is obsolete: true
This image shows a comparison of screens.
Right: Aurora screen with lightweight theme.
Left: Aurora screen with no theme.

The window controls and titlebar areas appear to have the same heights.

x86 Mac OSX 10.9.2
[bugday-20140409]
Attachment #8404169 - Attachment is obsolete: true
This image shows a screen comparison:
Right: Aurora with lightweight theme applied. Popup without tabs.
Left: Aurora with no theme applied. Popup without tabs.

The heights of the window control and the titlebar area appear to be the same on each screen. If you look really carefully on the left, you can see that the border around the address text box is the same height as on the right.

status-firefox30.0a2 verified

x86 Mac OSX 10.9.2
[bugday-20140409]
Attachment #8404145 - Attachment is obsolete: true
This was the sample test page used to apply the lightweight theme for the verification test:
https://bug511771.bugzilla.mozilla.org/attachment.cgi?id=457621

(In reply to lizardwalk5 from comment #16)
> Created attachment 8404180 [details]
> screen_aurora_ltw_theme_tabs_overlay.png
> 
> This image shows a comparison of screens.
> Right: Aurora screen with lightweight theme.
> Left: Aurora screen with no theme.
> 
> The window controls and titlebar areas appear to have the same heights.
> 
> x86 Mac OSX 10.9.2
> [bugday-20140409]

Comment 19

5 years ago
This issue is fixed and verified in [bugday-20140514] build.
You need to log in before you can comment on or make changes to this bug.