Closed Bug 967839 Opened 8 years ago Closed 8 years ago

onProfileShutdown work in BrowserGlue doesn't really have to happen at profile shutdown

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 30

People

(Reporter: mak, Assigned: mak)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

in bug 824433 I have a crash (explained in bug 967833 and https://bugzilla.mozilla.org/show_bug.cgi?id=824433#c36) that is actually caused by WebAppsUI.uninit() being called in profile-before-change.

So, while looking at that I figured that none of the stuff we have in _onProfileShutdown should actually happen at profile shutdown, it's all UI stuff that can and should shutdown earlier. Ideally should happen when the UI goes away, but since we can't rely on last-window-closed on Mac, we can likely use quit-application-granted.
This happened mostly cause it looks usual to put shutdown stuff in a nicely named shutdown method, so people just piled up stuff in _onProfileShutdown.

I'm going to move everything to q-a-g and remove the onProfileShutdown pitfall from browserGlue. This actually matters cause xpcshell is supposed to have a profile, but not a UI, stuff that controls the ui should generally not happen at profile shutdown.
Attached patch patch v1Splinter Review
Attachment #8370658 - Flags: review?(mano)
Whiteboard: p=0
Attachment #8370658 - Flags: review?(mano) → review+
https://hg.mozilla.org/mozilla-central/rev/9fb9effa74a6
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
No longer blocks: fxdesktopbacklog
Whiteboard: p=0
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.