Closed Bug 967907 Opened 6 years ago Closed 6 years ago

Change the in-product link to support

Categories

(Firefox for Metro Graveyard :: General, defect, P1)

28 Branch
x86
Windows 8
defect

Tracking

(firefox28 verified, firefox29 verified, firefox30 verified, b2g-v1.3 fixed)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox28 --- verified
firefox29 --- verified
firefox30 --- verified
b2g-v1.3 --- fixed

People

(Reporter: verdi, Assigned: mbrubeck)

References

Details

(Whiteboard: [release28] p=1 s=it-30c-29a-28b.1 r=ff28)

Attachments

(1 file)

We currently use https://support.mozilla.org/1/firefox/%VERSION%/%OS%/%LOCALE%/firefox-help to link to the support site from Settings > Help. This is the same url that we use for Desktop Firefox. SUMO needs a different link so that we can send touch users to a different landing page.

I propose that we use https://support.mozilla.org/1/touch/%VERSION%/%OS%/%LOCALE%/firefox-help

I wasn't able to verify with Ricky that this will work so I'll add a needs info for him.
Flags: needinfo?(rrosario)
(In reply to Verdi [:verdi] from comment #0)
> I propose that we use
> https://support.mozilla.org/1/touch/%VERSION%/%OS%/%LOCALE%/firefox-help
> 
> I wasn't able to verify with Ricky that this will work so I'll add a needs
> info for him.

This WFM!
Flags: needinfo?(rrosario)
Whiteboard: [feature] p=0
Assignee: nobody → mbrubeck
Whiteboard: [feature] p=0 → [release28] [feature] p=1 s=it-30c-29a-28b.1
Attached patch patchSplinter Review
Changes app.support.baseURL to:
https://support.mozilla.org/1/touch/%VERSION%/%OS%/%LOCALE%/

and changes the "Help (online)" link in the Settings charm to:
https://support.mozilla.org/1/touch/%VERSION%/%OS%/%LOCALE%/firefox-help
Attachment #8370489 - Flags: review?(jmathies)
Attachment #8370489 - Flags: feedback?(rrosario)
Status: NEW → ASSIGNED
Priority: -- → P1
QA Contact: jbecerra
Target Milestone: --- → Firefox 28
Comment on attachment 8370489 [details] [diff] [review]
patch

Review of attachment 8370489 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8370489 - Flags: feedback?(rrosario) → feedback+
Attachment #8370489 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/c31551a39157
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [release28] [feature] p=1 s=it-30c-29a-28b.1 → [release28] p=1 s=it-30c-29a-28b.1 r=ff28
Comment on attachment 8370489 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Metro

User impact if declined: Metro Firefox users directed to desktop Firefox support pages.

Testing completed (on m-c, etc.): On m-c since 2/7.

Risk to taking this patch (and alternatives if risky): Very low-risk Metro-only patch to change some in-product SUMO links.

String or IDL/UUID changes made by this patch: None.
Attachment #8370489 - Flags: approval-mozilla-beta?
Attachment #8370489 - Flags: approval-mozilla-aurora?
Went through the following issue for iteration IT-30C-29A-28B.1 (firefox30 verification), used the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-18-03-02-02-mozilla-central/

- Ensured taping/selecting "Help (online)" launches the correct link in fxmetro
--> https://support.mozilla.org/en-US/products/firefox-windows-8-touch?as=u&utm_source=inproduc

- Ensured taping/selecting "Help" launches the correct link in fxdesktop
--> https://support.mozilla.org/en-US/products/firefox?as=u&utm_source=inproduct

- Ensured that the fxmetro help webpage clearly display's "Firefox for Windows 8 Touch"
- Ensured that the fxdesktop help webpage clearly display's "Firefox"
- Ensured that the fxmetro knowledge base display's relevant Windows 8/Metro content (although currently very limited)
- Ensured that taping "Help (online)" correctly opens a new tab in the correct order under the Navigation App Bar
- Ensured that taping "Help (online)" correctly slides in the Navigation App Bar, opens the correct Tab and dismisses the Navigation App Bar
- Ensured that after several switches between the two environments (fxmetro & fxdesktop), the correct links are still being opened
- Went through the above test cases in different variations of snapped view without any issues

Used the following devices to test the following issue:
- MS Surface Pro 2 (Passed)
- Lenovo X1 Carbon (Passed)

Will be using the above test cases for Aurora/BETA verification once the uplift has been approved/landed
Attachment #8370489 - Flags: approval-mozilla-beta?
Attachment #8370489 - Flags: approval-mozilla-beta+
Attachment #8370489 - Flags: approval-mozilla-aurora?
Attachment #8370489 - Flags: approval-mozilla-aurora+
Target Milestone: Firefox 28 → Firefox 30
Went through the following issue for iteration IT-30C-29A-28B.1 (firefox30 verification), used the following build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-21-00-40-01-mozilla-aurora/

- Went through the test cases that have been added in comment #7 without any issues
- Ensured that the links from all the flyouts are directing users to the correct locations
- Ensured that all the flyouts under the "Settings" charm are working without any issues

Used the following devices to test the following issue:
- MS Surface Pro 2 (Passed)
- Lenovo X1 Carbon (Passed)

This didn't make it into 28.0b4, will finish verification once a new BETA is released.
Flagging for verification in tomorrow's Beta.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Verified as fixed with Firefox 28 beta 6 on Win 8 64-bit.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.