Need Ability to Sort Mail Accounts & Newsgroups in Mail/News Account Settings ("move-up, move-down)

VERIFIED DUPLICATE of bug 61078

Status

SeaMonkey
MailNews: Message Display
--
enhancement
VERIFIED DUPLICATE of bug 61078
17 years ago
14 years ago

People

(Reporter: Peter Lairo, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3+) Gecko/20010823

We should have "move up" and move down" buttons in the "Mail/News Account
Settings". 

Then we would also need two horizontal lines to delineate between the "mail
accounts *|* local folders *|* ewsgroups", because the moving cannot (should
not) go beyond ones own subgroup (mail accounts | local folders | newsgroups).
Another bug?

How it should look like:

+----------------------------------------------+
| Name1@myDomain.com
| Name2@myDomain.com
| Name2@myDomain.com
| ----------------------------------------
| Local Folders
| ----------------------------------------
| newsgroup1
| newsgroup1
| newsgroup1
|
+----------------------------------------------+
|   [ Move up ]  [ Move Down ]
| 
|   [ New Account    ]
|   [ Set as Default ]
|   [ Remove Account ]
+----------------------------------------------+
(Reporter)

Comment 1

17 years ago
1. The buttons should be grayed out if "Local Folders" is selected (unmovable).

2. The *Move-Down button* should be grayed out if selection is at the *bottom of
a group*.

3. The *Move-Up button* should be grayed out if selection is at the *top of a
group*.

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 61078 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.