Closed Bug 968084 Opened 6 years ago Closed 6 years ago

Context menu doesn't appear on list entries in Top Sites section

Categories

(Firefox for Android :: General, defect)

29 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox28 --- unaffected
firefox29 --- verified
firefox30 --- verified
fennec 29+ ---

People

(Reporter: paul.feher, Assigned: oogunsakin)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Build: Nightly 29.0a1 (2014-02-04), Aurora 29.0a2 (2014-02-04)
Device: Samsung Galaxy Nexus (4.3), ZTE x86 (4.0)

Steps to reproduce:
1. Access Top Sites section
2. Scroll and long tap on a list entry to access the context menu

Expected Results: 
The context menu should be displayed

Actual Results:
The context menu isn’t displayed
This recently changed as per UX decision right Margaret?
Flags: needinfo?(margaret.leibovic)
(In reply to Aaron Train [:aaronmt] from comment #1)
> This recently changed as per UX decision right Margaret?

Not that I know of. Sounds like a regression, maybe from bug 963404.
Flags: needinfo?(margaret.leibovic) → needinfo?(oogunsakin)
looks like its from that bug. i'll upload a patch
Flags: needinfo?(oogunsakin)
Assignee: nobody → oogunsakin
Status: NEW → ASSIGNED
Attached patch bug-968084.patch (obsolete) — Splinter Review
Attachment #8370950 - Flags: review?(margaret.leibovic)
Blocks: 963404
tracking-fennec: --- → 29+
Comment on attachment 8370950 [details] [diff] [review]
bug-968084.patch

Review of attachment 8370950 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the quick turnaround.
Attachment #8370950 - Flags: review?(margaret.leibovic) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4ad151ffd986
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 30
Sola, can you request approval to uplift this to aurora?
Flags: needinfo?(oogunsakin)
sure
Attached patch bug-968084.patchSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 968084
User impact if declined: Context menu wont appear on list entries in Top Sites section
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): no
String or IDL/UUID changes made by this patch:no
Attachment #8384728 - Flags: approval-mozilla-aurora?
Flags: needinfo?(oogunsakin)
Attachment #8384728 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8370950 - Attachment is obsolete: true
The context menu appears on list entries in Top Sites section, so:
Verified fixed on:
Build: Firefox for Android 29.0a2 (2014-03-05) and Firefox for Android 30.0a1 (2014-03-04)
Device: Alcatel One Touch
OS: Android 4.1.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.