Can't switch from Desktop to Metro mode with Firefox 28 beta 1

VERIFIED FIXED in Firefox 28

Status

defect
P1
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: manuela.muntean, Assigned: mbrubeck)

Tracking

28 Branch
Firefox 28
All
Windows 8
Dependency tree / graph

Firefox Tracking Flags

(firefox27 unaffected, firefox28+ verified, firefox29 verified, firefox30 verified)

Details

(Whiteboard: [beta28] [defect] p=1 s=it-30c-29a-28b.1 r=ff28)

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

5 years ago
With Firefox 28 beta 1, on both Win 8 64-bit and Win 8.1 64-bit

STR

1. Open Firefox and make it the default browser
2. Click on the "Relaunch in Firefox for Windows 8 touch" button to switch from Desktop to Metro mode

ER: the browser switches from Desktop to Metro mode
AR: the browser stays in Desktop mode (after clicking the browser, nothing happens)

Note: this works with latest Nightly and Aurora
Reporter

Updated

5 years ago
Severity: normal → blocker
Whiteboard: [triage]
Reporter

Comment 1

5 years ago
> Note: this works with latest Nightly and Aurora

To be more precise: Nightly 30.0a1 and Aurora 28.0a2
Whiteboard: [triage] → [triage] [defect] p=0
Here is my test:
1. Switch to Desktop mode
2. Download Firefox via Internet Explorer
3. Run the Firefox installer
4. Click 'Yes' on the UAC dialog
5. Opt for a 'Standard' installation and click 'Next' then 'Install'
> Firefox becomes installed
6. Opt to 'Launch Firefox now' and click 'Finish'
> Import Wizard appears
7. Opt to 'Don't import anything' and click 'Next'
> Firefox starts and prompts to become the default browser
8. Click 'Yes'
> Windows prompts, 'How do you want to open this type of link (http)?'
9. Click 'Firefox'
10. Click the 'Firefox' titlebar button
11. Click the 'Relaunch in Firefox for Windows 8 Touch' menu item
> Nothing happens
12. Quit Firefox and click the Firefox icon in the task bar
> Firefox starts in Desktop mode
13. Try to relaunch Metro mode via the Firefox button again
> Nothing happens
14. Quit Firefox and switch to Metro mode
15. Scroll the tiled interface until you find the 'Mozilla Firefox' tile
16. Touch the 'Mozilla Firefox' tile
> Firefox is started in Desktop mode

I repeated this test three times, first with Firefox 28.0b1, second with Firefox 28.0a2 2014-02-03, and third with Firefox 29.0a2 2014-02-04. Between each attempt I uninstalled Firefox, cleared all profile data, and set Internet Explorer to the default browser.

The results:
Firefox 28.0b1 could start in Desktop mode but not Touch mode
Firefox 28.0a2 could start in Desktop mode and Touch mode
Firefox 29.0a2 could start in Desktop mode and Touch mode

Given the above results I can only assume something is breaking in the build process.
Whiteboard: [triage] [defect] p=0 → [28beta][triage] [defect] p=0
Basically, it looks like users will not be able to run Firefox in Metro mode with the latest beta.

Comment 4

5 years ago
Maybe there's some build-level switch in effect that disables Metro mode based on channel (e.g. RELEASE_BUILD).
Assignee

Comment 5

5 years ago
Yes, it looks like we need to add --enable-metro to the official (beta/release) mozconfigs.

It's a separate bug that the menu item appears even without --enable-metro.  This probably affects Linux builds when the Firefox menu is displayed (menubar is disabled).
Assignee

Comment 6

5 years ago
Posted patch patch (obsolete) — Splinter Review
Add --enable-metro to all Windows mozconfigs.
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #8370872 - Flags: review?(jmathies)
Attachment #8370872 - Flags: review?(gps)
Assignee

Comment 7

5 years ago
Comment on attachment 8370872 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Metro Firefox

User impact if declined: "Relaunch in Windows 8 style" appears in Firefox menu but does nothing.

Testing completed (on m-c, etc.): Not yet tested; needs to land on beta for proper testing.

Risk to taking this patch (and alternatives if risky): Low risk -- makes beta/release mozconfig match what was already used for nightly and aurora.  Affects Windows beta/release builds only.

String or IDL/UUID changes made by this patch: None.
Attachment #8370872 - Flags: approval-mozilla-beta?
Attachment #8370872 - Flags: approval-mozilla-aurora?
You'll need to remove --enable-metro from the whitelist of allowed differences between beta/release and nightly, too: https://hg.mozilla.org/releases/mozilla-beta/file/951cd2dd1c86/browser/config/mozconfigs/whitelist#l63

(This probably should've been removed prior to the merge, and we would've caught this in pre-release checks.)
Assignee

Comment 9

5 years ago
Posted patch patch v2Splinter Review
(In reply to Ben Hearsum [:bhearsum] from comment #8)
> You'll need to remove --enable-metro from the whitelist of allowed
> differences between beta/release and nightly, too

Done, thanks.

(In reply to Matt Brubeck (:mbrubeck) from comment #5)
> It's a separate bug that the menu item appears even without --enable-metro.

Filed bug 968317 for this.
Attachment #8370872 - Attachment is obsolete: true
Attachment #8370872 - Flags: review?(jmathies)
Attachment #8370872 - Flags: review?(gps)
Attachment #8370872 - Flags: approval-mozilla-beta?
Attachment #8370872 - Flags: approval-mozilla-aurora?
Attachment #8370882 - Flags: review?(jmathies)
Attachment #8370882 - Flags: review?(gps)
Attachment #8370882 - Flags: approval-mozilla-beta?
Attachment #8370882 - Flags: approval-mozilla-aurora?
Comment on attachment 8370882 [details] [diff] [review]
patch v2

Review of attachment 8370882 [details] [diff] [review]:
-----------------------------------------------------------------

I think I'm a valid reviewer for this...r+.

It looks like you're already planning to do it based on the flags, but this should land on central, aurora, and beta.
Attachment #8370882 - Flags: review+

Updated

5 years ago
Attachment #8370882 - Flags: review?(jmathies)
Comment on attachment 8370882 [details] [diff] [review]
patch v2

It looks like we only need this on the beta branch, approving for immediate uplift.
Attachment #8370882 - Flags: approval-mozilla-beta?
Attachment #8370882 - Flags: approval-mozilla-beta+
Attachment #8370882 - Flags: approval-mozilla-aurora?
Attachment #8370882 - Flags: approval-mozilla-aurora-
Attachment #8370882 - Flags: approval-mozilla-aurora- → approval-mozilla-aurora+
(In reply to Lukas Blakk [:lsblakk] from comment #11)
> Comment on attachment 8370882 [details] [diff] [review]
> patch v2
> 
> It looks like we only need this on the beta branch, approving for immediate
> uplift.

We should land this on central and aurora to make sure that future uplifts don't regress this.
Assignee

Comment 13

5 years ago
Landed on beta with r=bhearsum:
https://hg.mozilla.org/releases/mozilla-beta/rev/cd1bfc373cfb

I'll land this on Aurora and trunk soon too.
Priority: -- → P1
QA Contact: jbecerra
Whiteboard: [28beta][triage] [defect] p=0 → [beta28] [defect] p=1 s=it-30c-29a-28b.1
Target Milestone: --- → Firefox 28
Reporter

Comment 15

5 years ago
Verified as fixed with Firefox 28 beta 1 build 2 (build ID: 20140205162153) on Win 8 32-bit and 64-bit and Win 8.1 32-bit and 64-bit: the browser switches from Desktop to Metro mode successfully.
https://hg.mozilla.org/mozilla-central/rev/f5fff3a6e939
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 28 → Firefox 30
Target Milestone: Firefox 30 → Firefox 28
Whiteboard: [beta28] [defect] p=1 s=it-30c-29a-28b.1 → [beta28] [defect] p=1 s=it-30c-29a-28b.1 r=ff28
Went through the following issue for it-30c-29a-28b-2 testing, used the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-18-03-02-02-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-18-00-40-01-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-beta/win32/en-US/ (Firefox Setup 28.0b3.exe)

- Went through the original test case from comment #0 without any issues
- Ensured that switching to fxmetro from fxdesktop is working right after a fresh firefox installation
- Ensured that you can switch between the two different environments without any issues (fxmetro/fxdesktop)
- Ensured that if fxdesktop is currently opened, taping/selecting the firefox metro tile will switch over to the desktop environment
- Ensured that if fxmetro is currently opened, taping/selecting the firefox icons will switch over to the metro environment
- Ensured that if fxdesktop was the latest environment opened, taping on all the firefox icons including the metro tile will launch fxdesktop
- Ensured that if fxmetro was the latest environment opened, taping/clicking on all the firefox icons including the metro tile will launch fxmetro
- Went through all of the above test cases using different variations of snapped view without any issues

Used the following equipment:
- MS Surface Pro 2 (Passed)
- Lenovo X1 Carbon (Passed)
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.